Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 31
  1. #1
    Matatan tocullo's Avatar
    Join Date
    Nov 2010
    Location
    VISTA AL RIO FL
    Posts
    1,725
    +1
    69

    This is not happening!!!!

    No hydro drags for me for this weekend!! SUCK !! After a nice tuning ride this past Sunday and the ski running very strong the nightmare happened... Some how my cylinders got full of water, I'm clue less at what could of happen. The ski was fine no signs of problems but when I got home didn't want to start. I just put this engine together after a full rebuild. Running open loop with the restrictor washer drilled to 11mm, could of this cause a head gasket failure? Any ideas on what could of happen?


  2. #2
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,037
    +1
    672
    head gasket. Were you in salt? Are you running head studs with OEM gasket like you should be?

  3. #3
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,991
    +1
    455
    How much water? Cracked cylinder?

  4. #4
    The most interesting man in the world. Nils888's Avatar
    Join Date
    Jun 2005
    Location
    California
    Posts
    4,230
    +1
    1,043
    Might be a bad Intercooler

  5. #5
    SLASHER's Avatar
    Join Date
    Jun 2007
    Location
    Australia, Perth WA
    Posts
    3,263
    +1
    474
    Yep intercooler ...

  6. #6
    You probably blew out the intercooler when you drilled out the restrictor. The pump can put out a lot of pressure; that is the reason for the restrictor!

  7. #7
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472

    Cool

    If your in need of some help pm me and I can give you my mechanics # .

    He's built many 90+ mph skis.
    He was at the world finals a few weeks ago and is going to the races in polk county this weekend. He has a stock pile of go very fast parts.

  8. #8
    Matatan tocullo's Avatar
    Join Date
    Nov 2010
    Location
    VISTA AL RIO FL
    Posts
    1,725
    +1
    69
    Not lot of water but enough to foul the plugs. I did a compression test and is ok cyl1 150, cyl2 150, cyl3 148. I got a question, if I drove the ski on the trailer with the water box full of water could the water rush back to the cyl? I have a +8 TDR.

  9. #9
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    I warned you about that pos box!

  10. #10
    Matatan tocullo's Avatar
    Join Date
    Nov 2010
    Location
    VISTA AL RIO FL
    Posts
    1,725
    +1
    69
    Quote Originally Posted by BigDaddyRXP View Post
    I warned you about that pos box!
    I know you did!!!! Do you think that was the cause??

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 750 SX stand up. Oops this is not a Polaris
    By 800AMSOIL4U in forum Polaris Projects
    Replies: 7
    Last Post: 04-24-2009, 11:10 AM
  2. This is what happens when you lend your ski...
    By GeoRXT in forum Sea Doo Open Discussion
    Replies: 42
    Last Post: 04-06-2009, 10:05 AM
  3. this is what happens!!!
    By TxVirageTx in forum Polaris PWC Performance
    Replies: 12
    Last Post: 02-27-2009, 07:25 PM
  4. This is not cool.
    By shawn alladio in forum High Performance Watercraft Safety
    Replies: 0
    Last Post: 03-21-2008, 12:03 PM
  5. Replies: 21
    Last Post: 08-15-2006, 10:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •