Results 1 to 6 of 6
  1. #1

    Possible pump cavitation?

    Finished rebuilding a 99' genesis carbed 1200 and took her out to break in. When giving it throttle is seems like the prop spins or isn't getting loaded for a second or two then it pulls great. Notice it more at low rpm's but happens through out. It doesn't feel like a motor bog. It sounds like a cavitation issue but I put sealer all around the ride plate to make sure there was any air leaks. Only other thing I can think of is the prop needs refurbished which I am going to do since I need to replace the thru hull seals.

    On the topic of prop, I just have the stock ss one. Is there a better one I should look for or just get a refurbished one? thanks

    edit: after reading another post sounds like the prop and the thru hull could be my problem causing "ventilation"


  2. #2
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Check clearance on your prop. Less than .010 is ideal. Replace the drive shaft seals too. I like Impros for refurbishing impellers.

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,576
    +1
    1,272
    Quote Originally Posted by BryanP View Post
    Check clearance on your prop. Less than .010 is ideal. Replace the drive shaft seals too. I like Impros for refurbishing impellers.
    Also check the wear ring surrounding the impeller for wear.

  4. #4

    Join Date
    Jun 2008
    Location
    windsor ont
    Posts
    640
    +1
    8
    impros does a great job.tell them what you want and they will do it

  5. #5
    Do I need to get the entire thru hull piece or is there a rebuild. I see driveline rebuild kits and sbt has the entire piece grease fitting and everything.

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,576
    +1
    1,272
    Quote Originally Posted by Flyboy8 View Post
    Do I need to get the entire thru hull piece or is there a rebuild. I see driveline rebuild kits and sbt has the entire piece grease fitting and everything.
    You can rebuild the through-hull bearing assembly. You can buy the individual parts yourself or you can buy a kit. I think Watcon still sells a nice kit, if I recall correctly.

    Note that there are two sintered metal Teflon impregnated bushings inside the OEM assembly. If those are worn they should be replaced at the same time the seals are replaced.

    Watcon also sells a complete aftermarket replacement assembly. It has steel bearings instead of a bushing and the coupler cover fits differently.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Polaris jet pump cavitating (ventilating)
    By motosyko in forum Polaris PWC Performance
    Replies: 10
    Last Post: 03-08-2013, 02:45 PM
  2. Pump cavitation, loosing grip?
    By dpowellmeii in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 08-23-2010, 06:08 AM
  3. '98 XPL Pump Cavitating
    By tall1 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 07-15-2010, 03:57 PM
  4. Possible Pump performance issue?
    By jakew4 in forum Yamaha Open Discussion
    Replies: 5
    Last Post: 10-26-2009, 09:25 PM
  5. pump cavitation
    By kawifan in forum Kawasaki PWC Performance (2-stroke)
    Replies: 3
    Last Post: 07-01-2009, 11:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •