Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23
  1. #1
    SLAP~YA's Avatar
    Join Date
    May 2013
    Location
    Sunshine Coast, QLD
    Posts
    432
    +1
    74

    Another modded FZR Lost top end

    Hey fella's
    yep this is another one of them threads I've done up my ski and it's gone slower.......

    i have even read through a few other threads with similar mods having the same problems but as we all know everyone's is different.

    heres where I'm at
    09 FZR 60hrs:
    ribbon removed
    Cold intake kit
    HKS BOV Kit
    Riva thru hull exhaust
    r&d aqua vein grate
    Riva ride plate
    Stage 2 VTECH ECU upgrade

    ski ran killer with all this and stock prop, only problem was it cavitated like crazy from hole shot, still only got 70mph

    so I've propped it to a skat trak swirl 13/23
    and it's back to 66mph at 7600 doesn't go a rev more
    also doesn't make a difference on what trim setting, flat water

    i dont have have a proper tach setup so it may be off slightly,

    The hole shot it crazy, if trimmed back it just jumps clean out the water, but in saying that I've defeantly gone backwards in top end.

    has anyone got any suggestions as to my next move? Props aren't cheap so I'm not inclined to buy another one to try?

    thanks heaps


  2. #2
    AWA MEMBER
    Join Date
    Jan 2008
    Location
    Currituck, North Carolina, United States
    Posts
    4,616
    +1
    247
    13/23 sounds a bit steep with stock boost I run that with 14psi of boost


  3. #3
    AWA MEMBER
    Join Date
    Jan 2008
    Location
    Currituck, North Carolina, United States
    Posts
    4,616
    +1
    247
    Try going with a 85mm exit nozzle you can pick up 200-300 rpm's that way.....or reduce pitch to 13/22




    BTW I love my Vtech flash, it pulls out of control from the holeshot, or a 20 roll.......does your pull like a raped ape? sounds like it if she leaps

    I wish I had a stalker to prove the Vtech 0-60 is faster than the R3, My buddy has a R3 and I can't wait till he replicates my setup but with a R3 to see what is faster

  4. #4
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    Quote Originally Posted by SLAP~YA View Post
    Hey fella's
    yep this is another one of them threads I've done up my ski and it's gone slower.......

    i have even read through a few other threads with similar mods having the same problems but as we all know everyone's is different.

    heres where I'm at
    09 FZR 60hrs:
    ribbon removed
    Cold intake kit
    HKS BOV Kit
    Riva thru hull exhaust
    r&d aqua vein grate
    Riva ride plate
    Stage 2 VTECH ECU upgrade

    ski ran killer with all this and stock prop, only problem was it cavitated like crazy from hole shot, still only got 70mph

    so I've propped it to a skat trak swirl 13/23
    and it's back to 66mph at 7600 doesn't go a rev more
    also doesn't make a difference on what trim setting, flat water

    i dont have have a proper tach setup so it may be off slightly,

    The hole shot it crazy, if trimmed back it just jumps clean out the water, but in saying that I've defeantly gone backwards in top end.

    has anyone got any suggestions as to my next move? Props aren't cheap so I'm not inclined to buy another one to try?

    thanks heaps
    what rpm's you want to turn.

  5. #5
    how much boost are you pushing? 23 is way to much and it is holding you back mind you i run 15psi and have a 15.5 22.5 pitch, i would work my way back and test with a pitch of 21,22.

  6. #6
    Hydrotherapy's Avatar
    Join Date
    Sep 2006
    Location
    The Rock
    Posts
    3,347
    +1
    17
    What did you rev with stock prop ? Rpm's ?

  7. #7
    Lakeside518's Avatar
    Join Date
    Jun 2007
    Location
    Clifton Park, NY
    Posts
    265
    +1
    16
    With that list of mods I agree, impeller is to steep! I would repitch to a 13/20.5 or 13/21. Or buy an IC & a B1 or LB wheel.

  8. #8
    Kristian Keppel Waterholics's Avatar
    Join Date
    Apr 2010
    Location
    Trinidad & Tobago
    Posts
    1,405
    +1
    38
    You have a V-TECH stage 2 and only turning 7600 RPM's. This is definitely your problem. You have too much pitch on that prop. Pitch it back and watch your ski fly

  9. #9
    Kristian Keppel Waterholics's Avatar
    Join Date
    Apr 2010
    Location
    Trinidad & Tobago
    Posts
    1,405
    +1
    38
    Just looked on the store and the rev limit for your ECU is 8500. Maybe Jim can chip in on the best pitch for your ski. Also you need a good tach.

    http://www.greenhulk.net/forums/showthread.php?t=208716

  10. #10

    Join Date
    Jul 2005
    Location
    Central North Carolina
    Posts
    3,847
    +1
    528
    " Put your stock prop back in with a 15 or16 /20 pitch on it" and get rpms back up to 8300_8400 and speed should be much better, Tommy Jordan

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. gpr lost top end speed
    By rich.allen in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 09-09-2012, 10:48 AM
  2. 07' 250X lost top end mph after parking for 20 min?
    By bzyguy in forum Kawasaki PWC Performance (4-stroke)
    Replies: 8
    Last Post: 07-23-2012, 06:00 PM
  3. FZR-Accleration vs Top End
    By sdman in forum Yamaha PWC Performance (4-stroke)
    Replies: 5
    Last Post: 07-07-2010, 08:44 PM
  4. Replies: 32
    Last Post: 06-22-2010, 08:32 PM
  5. rpm's o.k., lost top end
    By 2fast4me in forum 2-Stroke Performance
    Replies: 2
    Last Post: 05-09-2009, 07:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •