Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23
  1. #1
    gp1200rider's Avatar
    Join Date
    Mar 2008
    Location
    MD
    Posts
    987
    +1
    47

    No power no charger washers

    I just lost boost and pulled charger and no washers at all I had riva wahers .. this sucks


  2. #2
    mibunkerking's Avatar
    Join Date
    Aug 2008
    Location
    Jax,Fl
    Posts
    2,259
    +1
    117
    That really sucks. I hope the damage is not too bad.

  3. +1 by:


  4. #3
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Pics?
    Who built the SC?

  5. #4
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    I guess you know the motor has got to come out now to retrieve the washers.
    Good thing is that newer washers should be in 1 piece or Atleast larger pieces. Ceramics break in very small pieces.

    Who rebuilt the s/c???
    It shouldn't have just come apart if it was rebuilt correctly..

  6. #5
    gp1200rider's Avatar
    Join Date
    Mar 2008
    Location
    MD
    Posts
    987
    +1
    47
    I bought a x charger that was already rebuilt I rebuilt it for the hell of it and it looked fine , looked good checked the torq all good lasted 2 summers on my GPRXP , I just pulled motor and took pto cover off and found 4 pieces almost enough for 1 washer that’s it. So I guess I have to split the case .
    I just rblt motor 2 summers ago ugggh , my flywheel looks a little strange as well

  7. #6

    Join Date
    Mar 2006
    Posts
    1,829
    +1
    119
    both washers were missing?

  8. #7
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Flywheel has probably been eating the other washer...

    Yep time to rip her open....

  9. #8
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    dont forget to check your timing chain too..if you chewed up your flywheel theres a good chance you damaged your chain too..


  10. #9
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Definitely inspect every link of the timing chain... I would replace it just to be sure.


  11. #10
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    +1 on replacing the chain and inspect those oil pumps..
    Screens are going to have pieces..

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Lets hope no clutch washers fail on this one! :)
    By GasResearch-VT.SE in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 03-09-2013, 07:03 AM
  2. No Clutch Washers in Supercharger?? Ummm
    By fishman260 in forum 4-Tec Performance
    Replies: 9
    Last Post: 05-14-2011, 09:16 AM
  3. 2007 super charger washers
    By Louis914 in forum 4-Tec Performance
    Replies: 7
    Last Post: 06-24-2010, 12:34 PM
  4. super charger washers on RXP 2008
    By hazem_bawazir in forum 4-Tec Performance
    Replies: 19
    Last Post: 01-21-2008, 06:31 PM
  5. super charger washer install
    By ssvincels1 in forum 4-Tec Performance
    Replies: 2
    Last Post: 09-16-2007, 05:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •