Results 1 to 6 of 6
  1. #1
    ou812's Avatar
    Join Date
    Jun 2006
    Location
    Riverside,ca
    Posts
    6,210
    +1
    198

    Ignition stuck on after battery drained.

    So this P.O.S odessey battery won't hold a charge and while cranking the ski it went "Wha-whomp Wha-whomp" slowly several times and when I let go of the start switch it kept on going.. I had to disconnect the battery to stop it. When I connect the terminal up it cranks. I roughed up the switch a bit with a few back hands and thumps thinking it was stuck but nope.. I swapped starters, nope...
    It did this just before I tore the motor down a few months ago too.
    Any Ideas?


  2. #2
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Bad start solenoid. My Polaris machines use the same solenoid as the Sea Doo and I have had one stick in the on position and continuously crank the engine.


  3. #3
    canuck's Avatar
    Join Date
    May 2006
    Location
    The wet left coast.
    Posts
    1,088
    +1
    108
    Starter solenoid has welded the contacts together.

  4. +1 by:


  5. #4
    ou812's Avatar
    Join Date
    Jun 2006
    Location
    Riverside,ca
    Posts
    6,210
    +1
    198
    OK, I have a spare.. I'll give it a shot tomorrow before I shoot this ski....

    Thanks!

  6. #5

    Join Date
    Mar 2006
    Posts
    1,829
    +1
    119
    1+ -- starter solenoid. I had a few experiences too.

  7. #6
    ou812's Avatar
    Join Date
    Jun 2006
    Location
    Riverside,ca
    Posts
    6,210
    +1
    198
    Bad relay...
    All fixed. Now the fuel pump went, I wonder if its related?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ignition stuck on - 05' Seadoo RXT
    By crzdmn in forum 4-Tec Performance
    Replies: 6
    Last Post: 08-12-2012, 08:25 AM
  2. If I leave the key on will it drain the battery?
    By boater454 in forum Kawasaki Open Discussion
    Replies: 4
    Last Post: 08-31-2011, 04:58 PM
  3. Battery Drain after RED/PURPLE wire mod on SL 700
    By friscoboater in forum Polaris Open Discussion
    Replies: 2
    Last Post: 09-02-2010, 10:05 PM
  4. GP..Sitting Electrical Drain on your battery..
    By w/rpm500 in forum Yamaha Old School Skis
    Replies: 3
    Last Post: 05-15-2010, 07:58 AM
  5. Mode button not working! Stuck on Depth!
    By majundecid in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 08-04-2006, 07:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •