Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
  1. #1

    Join Date
    Jan 2010
    Location
    london england
    Posts
    144
    +1
    2

    MFD causing limp mode? Need replacement for Pro 1200 MFD

    Hi all,i've got a pro 1200 and after a while it will go into limp mode,but when i disconnect the 8 pin connection in the back of the mfd she runs properly,any ideas you guys?many thanks.


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,596
    +1
    1,276
    Does the MFD work properly? No water inside, display is clear and functional?

    Any warning message or red lamp while riding?
    Last edited by K447; 11-13-2013 at 11:06 PM.

  3. #3
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,529
    +1
    1,279
    +1

    a malfunctioning mfd makes the event which is triggering limp mode difficult to determine

    confirm battery charge rate, temp sensor operation and gas/oil levels any of those faulting can trigger limp mode.

    Could be a fault internal to the mfd..but make darn sure all the above are in order.

    please refine:

    "after a while"

    the amount of time running before faulting could be a clue..

  4. #4

    Join Date
    Jul 2011
    Location
    mass
    Posts
    44
    My 2001 genesis carb model would go into limp mode anywhere from 5-15 minutes of run time. Just like it was overheating. There was some moisture on display not much. Replaced mfd and was fine the rest of season.

  5. #5

    Join Date
    Jan 2010
    Location
    london england
    Posts
    144
    +1
    2
    thx for the response guys,the mfd is clear and all appears to work ok,however the mode button dos'nt change functions.she's not overheating or low on oil or fuel

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,596
    +1
    1,276
    Quote Originally Posted by jetskihowie View Post
    thx for the response guys,the mfd is clear and all appears to work ok,however the mode button dos'nt change functions.she's not overheating or low on oil or fuel
    Does the tachometer work? Accurate RPM display when engine is running?

  7. #7

    Join Date
    Jan 2010
    Location
    london england
    Posts
    144
    +1
    2
    yep rev counter works fine,also high amp new battery,other than this problem ski runs great,everyone loves it i have to fight to get on it!!

  8. #8
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,529
    +1
    1,279
    how long before it goes into limp..if shut and restarted does it reset?..how high is charging voltage?

  9. #9

    Join Date
    Jan 2010
    Location
    london england
    Posts
    144
    +1
    2
    if it go's into limp mode,i stop the engine disconnect the plug in the back of the mfd,restart engine an its like it never happened...
    don't know about the voltage but never had a problem with battery going flat.

  10. #10
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,596
    +1
    1,276
    Quote Originally Posted by jetskihowie View Post
    if it go's into limp mode,i stop the engine disconnect the plug in the back of the mfd,restart engine an its like it never happened...
    don't know about the voltage but never had a problem with battery going flat.
    Where are you located?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 11
    Last Post: 07-10-2012, 12:51 PM
  2. WTB MFD for Pro 1200
    By Mr. Matrix in forum Polaris Classifieds
    Replies: 12
    Last Post: 09-26-2011, 12:37 PM
  3. Pistons for Pro 1200
    By Hayabusa in forum Polaris PWC Performance
    Replies: 20
    Last Post: 11-16-2009, 04:48 PM
  4. TDR Water Box for PRO 1200 (water tap)
    By S12L00X in forum Polaris PWC Performance
    Replies: 10
    Last Post: 06-12-2008, 11:02 AM
  5. Hot Seat Water Box for Pro 1200
    By S12L00X in forum Polaris PWC Performance
    Replies: 17
    Last Post: 05-14-2008, 01:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •