Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 41
  1. #1
    Banned User
    Join Date
    Aug 2009
    Location
    Discovery Bay, CA
    Posts
    3,048
    +1
    336

    Broke my 300 again...

    Can you believe it, 120ish hours, 2race seasons, mixing up gas 100/91unleaded, ONE exhaust filter and it finally fouled one of the original plugs!? When will kawasaki ever figure it out? Hahaha


  2. #2
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129
    Sorry for your loss. You gonna part it out now

  3. +1 by:


  4. #3
    devils ride 250's Avatar
    Join Date
    Mar 2010
    Location
    lehigh valley pa
    Posts
    775
    +1
    124
    And that's with u spending countless hours maintaining it. Junk

  5. #4
    Banned User
    Join Date
    Aug 2009
    Location
    Discovery Bay, CA
    Posts
    3,048
    +1
    336
    Probably just use it for an anchor and get the ultimate ski.... seadoo spark!


  6. #5
    Self Confessed Day Dreamer toomanytoys's Avatar
    Join Date
    Sep 2008
    Location
    Sydney, Australia
    Posts
    1,932
    +1
    151
    It's all down hill from here. Next your going to break one of those plastic plugs that hold the battery cover on or have to straighten the foam behind the trim motor. I'm amazed they get back to the ramp in one piece sometimes. There is nothing worse than having to spend your hard earned coffee change on 300x parts!

  7. +1 by:


  8. #6
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Did you have to get towed by a Dooo or yamalog??

    They never foul plugs...

  9. #7
    devils ride 250's Avatar
    Join Date
    Mar 2010
    Location
    lehigh valley pa
    Posts
    775
    +1
    124
    Ya but the way back the seadoo carbon seal broke and it sunk

  10. +1 by:


  11. #8
    Not the least bit surprised Mike; it was bound to happen. You really need a Yamaha JB

  12. #9
    ou812's Avatar
    Join Date
    Jun 2006
    Location
    Riverside,ca
    Posts
    6,210
    +1
    198
    Quote Originally Posted by Mike H View Post
    Can you believe it, 120ish hours, 2race seasons, mixing up gas 100/91unleaded, ONE exhaust filter and it finally fouled one of the original plugs!? When will kawasaki ever figure it out? Hahaha
    Must have been afraid to change the plugs so they wouldn't snap off?

    That's actually pretty damn good on a set of plugs!

    BTW, I still have some NGK kawi plugs if anyone wants some.... Tommy? Mike? I have 11 I think...

  13. #10
    ou812's Avatar
    Join Date
    Jun 2006
    Location
    Riverside,ca
    Posts
    6,210
    +1
    198
    Quote Originally Posted by devils ride 250 View Post
    Ya but the way back the seadoo carbon seal broke and it sunk
    Damn right it broke and sank... Hauling a barge like that will wear down any seal, bearing or carbon....

Page 1 of 5 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Rebuilding my Carbs. AGAIN! Please chime in ... POP OFF and Springs Yama1200xlt 2005!
    By vjkevlar in forum Yamaha PWC Performance (2-stroke)
    Replies: 116
    Last Post: 07-29-2008, 12:20 PM
  2. A Polaris kicked my ass again! lol
    By javiert99 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 05-21-2007, 09:26 AM
  3. Broke my Reverse Bucket!
    By WildBill9000 in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-27-2006, 05:21 PM
  4. Got My $300.00 Gas Card
    By Dr Len in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 06-13-2006, 10:31 PM
  5. I broke my rideplate extension today
    By Green Hulk in forum 4-Tec Performance
    Replies: 28
    Last Post: 11-08-2005, 08:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •