Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1
    MPower's Avatar
    Join Date
    May 2005
    Location
    Raleigh, NC
    Posts
    3,340
    +1
    121

    Does anybody have a spare 05 RXP ECU?

    I need an 05 RXP ECU to use for testing for one day. I need to see if it solves an RPM issue on the ski.

    Let me know if you can help. Thanks


  2. #2
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    my 05 ecu stock map went to 100% DS around 10psi, vtec flash made a big differance

  3. #3
    MPower's Avatar
    Join Date
    May 2005
    Location
    Raleigh, NC
    Posts
    3,340
    +1
    121
    Im just looking for stock RPM on an OEM charger. There are no boost leaks, compression is good, and the ski wont go over 7700 rpm

  4. #4
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    808
    Quote Originally Posted by MPower View Post
    Im just looking for stock RPM on an OEM charger. There are no boost leaks, compression is good, and the ski wont go over 7700 rpm
    Do you have the piggyback harness for the knock sensor in place? If not, have you hooked the ski up to BUDS recently?

  5. +1 by:


  6. #5
    MPower's Avatar
    Join Date
    May 2005
    Location
    Raleigh, NC
    Posts
    3,340
    +1
    121
    Quote Originally Posted by JFizzleJR View Post
    Quote Originally Posted by MPower View Post
    Im just looking for stock RPM on an OEM charger. There are no boost leaks, compression is good, and the ski wont go over 7700 rpm
    Do you have the piggyback harness for the knock sensor in place? If not, have you hooked the ski up to BUDS recently?
    I do not think the piggyback harness is in place, need to check. The ski was recently on BUDS to have the VTS reactivated because it sat with no battery for a while and something got reset activating the GPS (none on the RXP obviously so it was throwing a code) and deactivating the VTS.

  7. #6

    Join Date
    Mar 2006
    Posts
    1,833
    +1
    119
    you may want to ask to use a "piggy back harness" for the day too.

  8. #7
    Boost addict hotbird's Avatar
    Join Date
    Jul 2011
    Location
    Southern WI
    Posts
    5,503
    +1
    681
    If it was hooked up to buds it got a automatic update that now requires the piggy back knock harness. Its shocking but true that most dealers are not aware of this.

  9. #8
    Boost addict hotbird's Avatar
    Join Date
    Jul 2011
    Location
    Southern WI
    Posts
    5,503
    +1
    681
    Put the harness on and you will notice more power and should get your rpms back.

  10. #9
    benGTST's Avatar
    Join Date
    Jul 2013
    Location
    Raleigh, NC
    Posts
    179
    +1
    8
    The updated harness was tried on this ski. Returned ski to dealer to see if the update was possibly installed incorrectly. Of course the dealer hasnt seen this update before, but i insisted the ski be hooked up to BUDS. Took it out for a ride and i get a knock sensor out of range code. I remove the harness on the water, code never reutned, and the RPMS are still around 7500.
    MPOWER and i have been looking for an ECU to try for awhile now. Its the last logical idea.
    Compression good (140 aross), oil level good( in the middle warm), fuel pressure good(58 psi), intercooler good(no leaks on the water, and bench tested), no boost leaks(pressure tested, no bubbles), spark plugs good (changed several times), prop good (swapped with known good rxp prop), superchager good (rebuilt by me because of this rpm loss, and measured slip several time 95 inch/lbs)

    I have posted several threads, posting pictures. With no results. I ride all year around, so naturally my rpms came up during the fall and winter. Summer months (80F-95F 7100 rpm 60 mph, winter months (45F-50F 7450-7500 @ 63 mph)

  11. #10
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Has the cam/gear been messed with latley

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. F/S 05 RXP ecu & matching throttle body
    By vxrpete8 in forum Sea Doo Classifieds
    Replies: 7
    Last Post: 05-19-2009, 12:30 PM
  2. Anybody have a 2006 rxt/rxp manual??
    By waverider in forum 4-Tec Performance
    Replies: 9
    Last Post: 08-25-2008, 09:51 AM
  3. Does anybody have this thing?
    By HallPass in forum Yamaha Open Discussion
    Replies: 3
    Last Post: 12-30-2007, 05:33 PM
  4. Does anybody have a bored out Throttle Body on the SC's
    By yellow4 in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-21-2007, 09:05 PM
  5. Does Anybody Have This Radio?
    By holdnon72 in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 05-04-2007, 10:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •