Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 27
  1. #1

    2005 rxp engine seized up after sitting for five years

    My 2005 rxp has been sitting for five years, I changed the plugs, gave it new gas then started it up. It ran perfectly after sitting for five years then seized up. Any suggestions?


  2. #2
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    Try posting in the Seadoo 4 stroke section.......

  3. #3
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Dropped valve or supercharger bearing let go would be my bet. Pull the spark plugs and see if any of them are damaged.


  4. #4
    I have purchased many skis that dropped a valve after sitting for an extended period. 2004- early 2006 model years.


    Quote Originally Posted by speedskixp View Post
    Dropped valve or supercharger bearing let go would be my bet. Pull the spark plugs and see if any of them are damaged.

  5. #5
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    Dropped valve. They were prone to fail

  6. #6
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Welcome aboard the Hulk!!!

    I have to agree with the other guys that after sitting for that long the valves are the weakest link and are very prone to failure.
    Been there and done that.

  7. #7
    How would I go about to check the valves.

  8. #8

    Join Date
    Apr 2005
    Location
    Jax,FL
    Posts
    2,677
    +1
    24
    Pull all the plugs out like speedskixp said and see if one of them is damaged..

  9. +1 by:


  10. #9
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Also if its still got ceramic clutch washers on the s/c I would pull it too.
    If they break and fall into the motor that's a whole lot more to fix..

  11. #10
    Removed the oil filter & look around the outside of the filter. If it is Bearing or oil related you will have metal on the outside of the filter. Remove the supercharger and see if the engine will turn over with starter. if not? i would remove the pump to check for driveline Brg issues. remove valve cover & check Timing chain, Check engine compression on all 3 cyls if you can get it to crank over? How long did it run before it stuck?

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Runs rough after sitting for a year
    By Alangsam in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 12-02-2013, 12:48 AM
  2. Replies: 2
    Last Post: 09-15-2013, 04:54 PM
  3. Yamaha gp1300r restart after sitting for three years
    By Flamered1500 in forum Yamaha Open Discussion
    Replies: 0
    Last Post: 05-09-2013, 09:26 PM
  4. No fire after sitting for one year!
    By jdjd in forum Polaris PWC Performance
    Replies: 5
    Last Post: 11-14-2011, 02:01 PM
  5. VX & FX engine oil leak after sitting for the winter
    By 01xdime in forum Yamaha Open Discussion
    Replies: 4
    Last Post: 03-14-2011, 08:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •