Page 1 of 3 123 LastLast
Results 1 to 10 of 24
  1. #1

    seadoo gti - sticking & increasing throttle problem??? - please help - thanks

    I have a seadoo gti le rfi which the throttle started sticking on when I was last out on it and now when I start out of the water - throttle keeps rising????

    I can get my hand on the throttle lever in the engine bay to stop it from increasing but have no idea how to go about fixing it?

    when I use the hand throttle on steering - it does not spring back?

    im assuming its the connection on the engine and not on the hand throttle? I don't want to start pulling it apart until I get some advise ?

    any advise would be greatly appreciated - thanks

  2. #2
    just been onto seadoo and they telling me that it would be more than likely the butterfly spring on the throttle body- at $110hr for 3-4 hrs fix I reckon its a rip off- has anyone got experience taking of the throttle / butterfly spring?

    ive only recently purchased the ski second hand - so maybe previous owner had over tightened it. :/ any info would be help thanks

  3. #3

  4. #4
    hey jim thanks for the advise- is the throttle body easy to pull off? thanks for your help

  5. #5

    Join Date
    Mar 2006
    I can install all the parts there in about 1.5 hours from taking everything off a ski to being ready to go to the water.

  6. #6
    Myself's Avatar
    Join Date
    May 2007
    North Central Arkansas
    Remove the flame arrestor to access throttle body first. Unhook the throttle cable end from the throttle body (without loosening the 10mm nuts) and check the throttle lever itself for proper movement. If it operates smoothly and feels spring loaded then the problem lies in your cable.

  7. #7
    ok thanks ill do that tomorrow and report back - please let it be only the cable - thanks

  8. #8
    hey jim & my self - I pulled the throttle cable as advised & yes its the cable- the butterfly spring seems to be in good working order - not sticking etc.- so im just about to ebay one now.

    But.. I noticed that there was another shorter cable running back from throttle body to the front of on the ignition casing? that cable runs onto another lever - Oil Pump Ass'y - which is moving freely & not springing back to any particular point????????? the more I look the more problems I find- live n learn eh? anyway......

    It looks broken for a while, the previous owner said it is oil injected and not premixed- the ski is quite smokey on start up so im assuming there is oil getting through.

    I def bough a piece of cr#p - any advise besides sinking it????? ebay an oil pump and refit? anyone got any experience with pulling this apart before I butcher it?

    I did do a compression check on cylinders -both at 160 so maybe there is still hope for this ski with a little tlc

  9. #9
    here is the assembly for your reference - any help is greatly appreciated! thanks

    Click image for larger version. 

Name:	seadoogti.jpg 
Views:	120 
Size:	60.1 KB 
ID:	319148
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	seadoo gti.jpg 
Views:	86 
Size:	58.6 KB 
ID:	319147  

  10. #10
    Myself's Avatar
    Join Date
    May 2007
    North Central Arkansas
    Get us a pic. It's possible the lever was in the wrong position when the cable was attached. It probably needs to be "wound" back into proper position. Easy to do.

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 04 Seadoo Gti Le Rfi not charging problem
    By Spider228 in forum 2-Stroke Performance
    Replies: 12
    Last Post: 08-12-2013, 01:58 PM
  2. Seadoo xpdi 2003 problems! Please help?
    By Kimarne in forum 2-Stroke Performance
    Replies: 1
    Last Post: 05-16-2012, 04:24 PM
  3. 2006 Seadoo Rxp Engine,RPM Problem. Please Help!
    By gotach in forum 4-Tec Performance
    Replies: 8
    Last Post: 07-22-2010, 12:16 AM
  4. 96 seadoo xp problem please help
    By dynasty8314 in forum 2-Stroke Performance
    Replies: 15
    Last Post: 07-02-2010, 02:43 PM
  5. 03 seadoo xp di problems Please help
    By macattack in forum 2-Stroke Performance
    Replies: 1
    Last Post: 05-21-2009, 07:51 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts