Results 1 to 6 of 6
  1. #1

    Join Date
    Apr 2005
    Location
    Jax,FL
    Posts
    2,677
    +1
    24

    need-hoses-sensor-trim

    Looking for RXP or rxpx ride plate coolant hoses,chrome trim that goes around gauge 04/05 type and speed sensor ?03/10 type...Thank u Todd


  2. #2
    Steve STSPERFORMANCE's Avatar
    Join Date
    Dec 2007
    Location
    Cambridge, Ohio
    Posts
    2,701
    +1
    116
    I think I have the hoses

  3. #3
    A smart admits!A wicked excuses!An idiot insists! mitsakosgt's Avatar
    Join Date
    Jun 2008
    Location
    GREECE ATHENS , NAXOS
    Posts
    2,691
    +1
    40
    I have the speed sensor...

  4. #4
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    I have all cooling hoses from an 07 RXT (just went open loop), and might even have a speedo sensor around. Let me know Todd

  5. #5

    i got u

    Quote Originally Posted by psycho rxp View Post
    I have all cooling hoses from an 07 RXT (just went open loop), and might even have a speedo sensor around. Let me know Todd
    I have everything on your list

  6. #6

    Join Date
    Apr 2005
    Location
    Jax,FL
    Posts
    2,677
    +1
    24
    [QUOTE=jetskiland;2303566]
    Quote Originally Posted by psycho rxp View Post
    I have all cooling hoses from an 07 RXT (just went open loop), and might even have a speedo sensor around. Let me know Todd
    I have everything on your list[/sent pmQUOTE]

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need Hose connector for water box Sl750
    By massguy in forum Polaris Open Discussion
    Replies: 2
    Last Post: 11-09-2008, 07:53 AM
  2. Need Help! My Trim Is Killing Me
    By xanthras in forum Polaris Open Discussion
    Replies: 20
    Last Post: 08-18-2008, 11:15 AM
  3. I Need that sensor that goes on the waterbox!
    By GeoRXT in forum Sea Doo Classifieds
    Replies: 3
    Last Post: 07-29-2008, 07:17 PM
  4. Need help with trim wiring
    By Rodneyae in forum Polaris How To & FAQs
    Replies: 8
    Last Post: 03-06-2007, 04:31 PM
  5. 2004 GPR not needing Car Sensor Chip???
    By Chrisrokc in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 06-22-2006, 08:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •