Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1
    Tjdriver's Avatar
    Join Date
    May 2012
    Location
    Eglin AFB
    Posts
    485
    +1
    4

    Genesis fuel issue

    I finally put my motor back together and dropped it in the ski. Everything is hooked up and ready to go. I'm not getting any fuel into the motor. I can pour some down the carbs and it cranks and runs.

    I pulled the electrical connector to the fuel pump/sender and it's showing 12v then 22v when I hit the start button.

    Any ideas?


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    The fuel pump is mounted to the carbs. Pull the return off the tank and blow into the tank return till you get fuel out the carb return line.

  3. #3
    Tjdriver's Avatar
    Join Date
    May 2012
    Location
    Eglin AFB
    Posts
    485
    +1
    4
    So it just needs to be primed? Copy

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,569
    +1
    1,272
    Quote Originally Posted by Tjdriver View Post
    I finally put my motor back together and dropped it in the ski. Everything is hooked up and ready to go. I'm not getting any fuel into the motor. I can pour some down the carbs and it cranks and runs.

    I pulled the electrical connector to the fuel pump/sender and it's showing 12v then 22v when I hit the start button.

    Any ideas?
    This is a fuel injected engine?

    No priming required for the fuel injection fuel system. The fuel injected engines have an electric fuel pump in the fuel tank. If the electric fuel pump is not running (no fuel pressure and no fuel flow at the Schrader tee valve) you need to diagnose why.

    If you have fuel pressure but no actual fuel injecting, then some diagnostics are needed.

  5. #5
    Tjdriver's Avatar
    Join Date
    May 2012
    Location
    Eglin AFB
    Posts
    485
    +1
    4
    No K, It's a carbd Genesis.

    I must be retarded cuz I can't get any fuel to flow to thru the lines. I tried blowing on the return hose and nothing.

  6. #6
    Tjdriver's Avatar
    Join Date
    May 2012
    Location
    Eglin AFB
    Posts
    485
    +1
    4
    I must have the hose routing wrong.

    Feed line going to the T next to the fuel pump.
    Line from block by mag cyl going to pump.
    Return line from center carb to tank.
    Line from block by PTO cyl going to PTO carb.

    Is this correct?

  7. #7
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Start at the tank and verify the routing and presence of flow. The tank nipples are labeled. When you blow in the return line to the tank does it pressurize?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Polaris_2002_Service_Manual_(9917370)_01.jpg 
Views:	27 
Size:	28.6 KB 
ID:	319870  

  8. #8
    Tjdriver's Avatar
    Join Date
    May 2012
    Location
    Eglin AFB
    Posts
    485
    +1
    4
    I used the diagram from parts pit stop to route the lines.

    When I blow in the tank it pressurized but doesn't push fuel out

  9. #9
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Remove the fuel out and see if it flows then follow to the next component.

  10. #10
    Tjdriver's Avatar
    Join Date
    May 2012
    Location
    Eglin AFB
    Posts
    485
    +1
    4
    no flow at all

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Genesis fuel issue
    By Gstuart in forum Polaris Open Discussion
    Replies: 8
    Last Post: 04-30-2014, 04:04 PM
  2. 2001 Polaris Genesis Fuel Injected Issues
    By J4ke1990 in forum Polaris PWC Performance
    Replies: 3
    Last Post: 06-10-2013, 10:33 PM
  3. Need help with fuel issue on 2000 genesis (carb)
    By Dstox in forum Polaris How To & FAQs
    Replies: 9
    Last Post: 06-15-2012, 03:31 PM
  4. 1999 Polaris Genesis fuel issue, Please help.
    By battline in forum Polaris Open Discussion
    Replies: 1
    Last Post: 05-23-2012, 08:07 PM
  5. Anyone have fuel issues at MB ?
    By WFO in forum Mudbug Nationals PWC.Life Rally
    Replies: 67
    Last Post: 06-21-2007, 11:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •