Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 39
  1. #1
    dpracing's Avatar
    Join Date
    Jan 2008
    Location
    Palm Beach, Florida
    Posts
    1,244
    +1
    246

    Anybody ever mess with cam timing?

    Just curious if there are any gains to be had in the upper rpm range. My ski won't rev any higher than 8700 no matter what I do.

    Somebody suggested cam timing?

    Any my thoughts or suggestions would be appreciated.


  2. #2

  3. #3
    Boost addict hotbird's Avatar
    Join Date
    Jul 2011
    Location
    Southern WI
    Posts
    5,503
    +1
    681
    So you bent the prop and it did not gain any rpms?

    Cam timing will give or take topend power but you should still be able to rev it to the limiter if you take prop pitch away.

    Do you have logs?

  4. #4
    dpracing's Avatar
    Join Date
    Jan 2008
    Location
    Palm Beach, Florida
    Posts
    1,244
    +1
    246
    Quote Originally Posted by hotbird View Post
    So you bent the prop and it did not gain any rpms?

    Cam timing will give or take topend power but you should still be able to rev it to the limiter if you take prop pitch away.

    Do you have logs?
    Nothing I can post. But the data recorded is limited w vtech. Andy has looked at my logs w mega log viewer and has not seen anything out of order.
    I have:
    removed 2 mil from prop and gained nothing 8650-8700
    put STOCK prop in same rpm
    replaced stock water box w Riva same rpm
    bypassed resonator same rpm
    afr from 11.0 -12.9 same rpm
    85 degree air to 63 degree air same rpm

    ​wtf?

    Im going out of my skull here.....

    Cam timing?
    engine alignment ?

  5. #5
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    What ECU are you using?

  6. #6
    Boost addict hotbird's Avatar
    Join Date
    Jul 2011
    Location
    Southern WI
    Posts
    5,503
    +1
    681
    Sounds ecu related?
    Maybe one of the limiters was not removed with vtech?

    Can you log your throttle position?

  7. #7
    GRF + DashPac:) seadoo02xp's Avatar
    Join Date
    Apr 2005
    Location
    MO
    Posts
    4,559
    +1
    948
    Sounds like a tune issue. If it's a limiter that isn't removed that mega log viewer crap won't pick it up anyway. You should email jonatan and have him review your setup . Back when I ran vtech I hit a boost limiter that was set at 14.7 psi. With an et140 you may be on that limiter

  8. #8
    Boost addict hotbird's Avatar
    Join Date
    Jul 2011
    Location
    Southern WI
    Posts
    5,503
    +1
    681
    Quote Originally Posted by seadoo02xp View Post
    Sounds like a tune issue. If it's a limiter that isn't removed that mega log viewer crap won't pick it up anyway. You should email jonatan and have him review your setup . Back when I ran vtech I hit a boost limiter that was set at 14.7 psi. With an et140 you may be on that limiter
    Agree if you can log throttle opening you would see the throttle closing up top when and if it hits a limiter.

  9. #9
    dpracing's Avatar
    Join Date
    Jan 2008
    Location
    Palm Beach, Florida
    Posts
    1,244
    +1
    246
    Quote Originally Posted by beerdart View Post
    What ECU are you using?
    Stock ecu w vtech, same base tune as a few guys on here running hi boost and rpm

  10. #10
    GRF + DashPac:) seadoo02xp's Avatar
    Join Date
    Apr 2005
    Location
    MO
    Posts
    4,559
    +1
    948
    Quote Originally Posted by dpracing View Post
    Quote Originally Posted by beerdart View Post
    What ECU are you using?
    Stock ecu w vtech, same base tune as a few guys on here running hi boost and rpm
    Ya same base tune but this could be specific to your skis ecu software . Get a hold of jonatan I bet he can help more so than Andy . I don't know if Andy can dig as deep into the ecu as jonatan can

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. anybody ever have a cam they can't get out?
    By joewharton2 in forum 4-Tec Performance
    Replies: 17
    Last Post: 01-29-2012, 11:21 AM
  2. some help needed with cam timing
    By Bastiaan maarten Bok in forum 4-Tec Performance
    Replies: 4
    Last Post: 11-11-2007, 06:02 PM
  3. Anybody ever see this problem with their 15F
    By kawiultra99 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 8
    Last Post: 06-13-2007, 07:49 PM
  4. Anybody mess with this?
    By Jarrett in forum 4-Tec Performance
    Replies: 6
    Last Post: 05-26-2006, 09:30 AM
  5. Cam Timing with RR ECU
    By somefun in forum 4-Tec Performance
    Replies: 1
    Last Post: 05-14-2006, 06:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •