Results 1 to 9 of 9
  1. #1

    Join Date
    Oct 2013
    Location
    Brisbane, Australia
    Posts
    16

    Msx150 turbo info needed

    Hey guys,
    Can anyone tell me how large the mouth of the turbo compressor is in the Msx150?
    I've just paid a lot of money for a new turbo cartridge and the compressor impeller is too big for the housing. Also what is the difference between the 110 and 150 turbo?

    Thanks guys


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,587
    +1
    1,272
    What turbo cartridge specs or model did you buy?

  3. #3
    ripcuda's Avatar
    Join Date
    May 2010
    Location
    Newman Lake, WA
    Posts
    2,389
    +1
    166
    The factory service manual lists the stock turbo (same one for both MSX 110/150) as a '3K Warner'... but doesn't list any measurements for the turbo. Sorry... but I don't have access to one that I could measure for you right now.

    Randy at Weber Power should know... give him a call. Or possibly Martin at Precision Sports... he used to offer bigger turbos.

    Cheers!

  4. #4
    Kosh's Avatar
    Join Date
    Sep 2007
    Location
    Australia
    Posts
    1,483
    +1
    83
    If its speced from an Audi it will be a hi flow front wheel which is good! You do need to Profile the front cover to suit. I have done this once before.Can do a measure on stock when my stuff arrives from the movers.

  5. #5

    Join Date
    Oct 2013
    Location
    Brisbane, Australia
    Posts
    16
    He's supplied me with a 5303-710-0504 chra. This is the same as the one I'd previously ordered from China for $200. I had to swap the new compressor wheel with the original one I had which meant it wasn't balanced so I thought I'd spend the money and get one made locally. As soon as I got it home (after a 2 hour round trip) I realised the housing wouldn't fit so I'm really hoping that he's supplied the wrong one otherwise I'll have to hunt around for a new compressor housing...

  6. #6

    Join Date
    Oct 2011
    Posts
    143
    +1
    17
    Matfan,

    Did you get this resolved?
    I think I know what happened, and might have a solution. I'm sure you fixed it by now?

    Regards,
    Randy

  7. #7

    Join Date
    Oct 2013
    Location
    Brisbane, Australia
    Posts
    16
    Hi Randy,

    Yeah it looks as though the previous owner replaced the stock turbo with the msx110 one. The turbo shop actually had a spare housing so it's all gravy now. My current problem is the bloody thing won't boost! I installed an aftermarket boost gauge to try and figure out what was happening. Under load the gauge is showing no boost, but also no vacuum so it is working. I assume there's a leak somewhere, possibly the intercooler. I removed the wastegate actuator line to check that it wasn't the solenoid but saw no change. I've had the bloody engine out about 5 times already so I'm going to take my time and get it all right once and for all. Any hints would be greatly appreciated.

  8. #8
    ripcuda's Avatar
    Join Date
    May 2010
    Location
    Newman Lake, WA
    Posts
    2,389
    +1
    166
    Where is your boost gauge hooked up? Only place you ever see vacuum is off the intake manifold... after the throttle body.

    Do you hear any loud hissing (boost leak) when getting on it? How about an odd honking noise (BOV venting)?

    I've seen a tear/cut in the backside of the turbo-to-intercooler hose... that would have been easy to miss. And I've had my intercooler-to-hardpipe hose pop off while riding... but that's pretty obvious and easy to see.

    Does it idle rock steady? If so, that would rule out the throttle body to intake mani rubber boot. If it leaks there... idle will be erratic.

    If all that checks out... could be a leaking intercooler. Would need to cap off one opening and pressurize the other... 20psi should be fine... and it should hold the pressure. I've made some pugs/caps to this job with some 2in (?) pvc caps... with one having a tire valve in the middle so I could put pressure to it. They fit inside the hoses well and can be clamped down... but they often pop out under pressure and go ballistic and make a gunshot loud bang when they pop. So be careful.

    Cheers!

  9. #9

    Join Date
    Oct 2013
    Location
    Brisbane, Australia
    Posts
    16
    Yeah the boost gauge is hooked up after the throttle body so I should be getting an accurate reading. There isn't any hissing or honking that I could hear and it idles perfectly, it's a bit of a head scratcher. It'll only rev to between 4400 and 4600rpm but I've ruled out anything electronic as it revs freely when not under load. I'll try and rig up a pressure tester this weekend but after all the work I've done and the frustrating results I'm finding it a little difficult to get motivated.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Coolant drain info needed
    By camar0 in forum 4-Tec Performance
    Replies: 21
    Last Post: 03-27-2010, 01:55 AM
  2. B-kit prop pitch w/ 15-19r, Info needed.
    By Water4fire in forum 4-Tec Performance
    Replies: 13
    Last Post: 05-14-2007, 08:30 AM
  3. RXP 15/19R Info needed
    By suck my wake in forum 4-Tec Performance
    Replies: 62
    Last Post: 04-18-2007, 01:21 PM
  4. Info Needed!!
    By WaveJumper52 in forum Yamaha Old School Skis
    Replies: 44
    Last Post: 01-11-2007, 09:27 PM
  5. Mechanical speedo info needed
    By Rodneyae in forum Polaris Open Discussion
    Replies: 6
    Last Post: 12-28-2006, 09:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •