Results 1 to 5 of 5

Thread: 2004 sc rxp

  1. #1
    derwin66's Avatar
    Join Date
    Oct 2007
    Location
    Brisvegas, Australia
    Posts
    64

    2004 sc rxp

    Hi people. I am after some advice on my above ski. I am on 3 weeks leave and a long way from anywhere. Took the ski out wave jumping and I got a 2 second beep every 10 or so minutes. Got back in and checked everything and it all looked fine. No fault codes popped up at the time. The ski is running well. Can I ride it for one more week before I take it to the mechanic to read it with the buds? Or is there anything I should check for? Thanks


  2. #2
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    807
    Quote Originally Posted by derwin66 View Post
    Hi people. I am after some advice on my above ski. I am on 3 weeks leave and a long way from anywhere. Took the ski out wave jumping and I got a 2 second beep every 10 or so minutes. Got back in and checked everything and it all looked fine. No fault codes popped up at the time. The ski is running well. Can I ride it for one more week before I take it to the mechanic to read it with the buds? Or is there anything I should check for? Thanks
    Could be the TOPS giving a false reading because the extreme angles that happen in wave jumping. Hit the set button 5 times to see any stored codes. Does the engine stumble when the alarm beeps?

  3. #3
    derwin66's Avatar
    Join Date
    Oct 2007
    Location
    Brisvegas, Australia
    Posts
    64
    There is no stored codes and it does stumble for the two seconds the beeper is going off

  4. #4
    canuck's Avatar
    Join Date
    May 2006
    Location
    The wet left coast.
    Posts
    1,088
    +1
    108
    I have a similar thing going on with mine.

    http://www.greenhulk.net/forums/showthread.php?t=206400

    Motor is out right now getting Supertech valves and I plan on having a look at the TOPS valve. Mine does not beep when it stumbles and it only stumbles for a few seconds, machine runs great otherwise with no stored codes. Let us know if you figure out the problem.

  5. #5
    derwin66's Avatar
    Join Date
    Oct 2007
    Location
    Brisvegas, Australia
    Posts
    64
    Canuck I am pretty sure mine is a electrical fault after checking the service manual. Mine works fine then after 10 to 15 minutes it beeps once for two seconds and then it stumbles then works fine for another 10 minutes and does the same. I will have to get the buds to find the fault. It is overdue for a service anyhow

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Best oil to use in a 2004 seadoo rxp 215hp sc?? Oil change video?
    By vicario62590 in forum 4-Tec Performance
    Replies: 14
    Last Post: 05-14-2014, 09:15 AM
  2. performance mods for non sc rxp
    By JRoX85 in forum 4-Tec Performance
    Replies: 8
    Last Post: 11-01-2007, 09:19 PM
  3. 2004 Stock Rxp 7700-7800rpms Max
    By JBasco20 in forum 4-Tec Performance
    Replies: 4
    Last Post: 08-07-2007, 03:10 PM
  4. 2004 sc upgrade to 2006 sc
    By daverxp4 in forum 4-Tec Performance
    Replies: 11
    Last Post: 04-25-2007, 05:46 PM
  5. Ceramic Hybrid sc , RXP 2006
    By LAB69 in forum 4-Tec Performance
    Replies: 2
    Last Post: 02-01-2007, 05:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •