Results 1 to 5 of 5
  1. #1

    '03 Sportster Engine Problems

    Recently purchased an '03 Sportster with a single 951CC engine. Ran well at first but now wont go past half throttle or about 5500RPM without feeling like its hitting a rev limiter. Somewhat hard to start and seems to be running rich. Fresh fuel, Sea-Doo oil, new plugs. Have replaced the rectifier/voltage regulator (not sure that's what it's called) but no improvement. I'm told these are complex engines and I'm not sure I'm the one to be messing with it but thought someone on the forum could help with something simple that I might be missing. Thanks in advance for any help or if more info is needed, let me know.


  2. #2
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    1st you need to compression test it.
    Is it a fuel injected model or carb?
    If its a carb model then they probably need rebuilt.
    Also did you install new fuel filters?

  3. #3
    Thanks for your reply. It is fuel injected and I Haven't changed the filter but because it seems to be running rich I didn't think it would be the filter. However, since when I bought it, it had been sitting for some time, so it is possible that it could be the filter. At any rate, it would be simple and easy to try that. Thanks again.

  4. #4
    R-Doo's Avatar
    Join Date
    Sep 2006
    Location
    Minnesota
    Posts
    833
    +1
    77
    Besides the fuel filter change the water separator filter. It looks like an oil filter with a wire on the bottom.

  5. #5
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Run a double dose of fuel Injector cleaner thru it.
    I use Lucas fuel Injector cleaner.
    Walmart has 64oz bottles for $10.
    It also says it neutralizes old fuel.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 gtx 4tec Check Engine problem.
    By kabab in forum 4-Tec Performance
    Replies: 11
    Last Post: 04-28-2009, 03:30 AM
  2. 03 GTX SC problem
    By joelykool in forum 4-Tec Performance
    Replies: 13
    Last Post: 05-15-2007, 10:48 PM
  3. Help with 03 Sportster 4 TEC Mods
    By btheboat in forum Sea Doo Sport Boats
    Replies: 5
    Last Post: 09-25-2006, 04:41 PM
  4. Engine Problem, top speed RPM lost
    By BlackHawk in forum 4-Tec Performance
    Replies: 11
    Last Post: 08-30-2006, 01:34 PM
  5. 02 GP 1200 engine problems
    By ADAMBOMB in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 06-23-2006, 12:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •