Results 1 to 2 of 2
  1. #1

    1987 X2 hull / bildge / water supply question?

    Three fittings to the right of the pump:

    Top one is not connected and drains water while on-hose.

    Middle fitting is for the bilge
    Bottom fitting is for the cooling system.

    I was planning to lake-test my ski today. SHould I be concerned that the top fitting has nothing connected??

    Thank you

  2. #2
    Found out, its normal. Ski ran great on the lake today in 45 degree water

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Thru hull intake water repelliing product
    By Jeff C in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 10-26-2006, 03:43 PM
  2. New jetworks kit water dump question
    By Mongoose in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 04-14-2006, 08:25 AM
  3. Water leak question for Harry Klemm
    By RichGPR in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 02-17-2006, 09:22 PM
  4. Another water ingestion question
    By Denali44 in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-08-2005, 04:31 PM
  5. Foam in hull works -- water up over top of engine today....
    By VFX_Artist in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 08-01-2005, 11:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts