Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21

Thread: Ski won't start

  1. #1
    spouk3's Avatar
    Join Date
    Mar 2012
    Location
    Montreal, QC, Canada
    Posts
    635
    +1
    30

    Ski won't start

    Hi,

    I wanted to start my ski to check if FPR is adjust correctly and also adjust the AFR at IDLE ... Well ski won't crank ... It tries to but engine doesn't turn ... On the dash, I have the "ENGINE light" and all the other light are kinda "dimming" when I crank the engine ...

    Ski as not been running since end of September (it's winter here) does this sound like a battery issue? Also, it tries to crank maybe one time and it looks like the dash is resetting (like if I put the key in).


    I think I need help


  2. #2
    showmepro1200's Avatar
    Join Date
    Sep 2006
    Location
    Jefferson City MO (Ride at Lake of the Ozarks)
    Posts
    524
    +1
    40
    Battery would be my bet. Not a seadoo mechanic by any means, just sounds that simple though.

  3. #3
    spouk3's Avatar
    Join Date
    Mar 2012
    Location
    Montreal, QC, Canada
    Posts
    635
    +1
    30
    It's like if I hear one crank and then it dies and dash reset ... Battery maintainer was not connected since a long time... I plugged it like 3 weeks ago and before that I have wake the ski a lot when installing boost gauge and AFR gauge without starting the engine ... So yeah, battery may not have enough charge... But still dash and gauges works ...

    But I think the engine need a lot more amps to start...

  4. #4
    You didn't mention the age of the battery, but some of the replacements don't have the same amps as the factory ones and don't last nearly as long.
    Also, my PX had fouled plugs after only 10 hours . The machine wouldn't crank over and after a minute the cranking stopped completely.
    I was lucky to be at the marina, the mechanic reset something, put in new plugs and it was like new.

  5. #5
    spouk3's Avatar
    Join Date
    Mar 2012
    Location
    Montreal, QC, Canada
    Posts
    635
    +1
    30
    Battery is original... 2 years old... The seadoo crank about 3 month ago... I will try to charge it and I'll see... It won't even crank... It's trying lights on dash dim when I do that... And the, the dash reset and I ear the "beep beep" it's weird... But it looks like it's the batterie... Normally, when you plug the wire on the battery there's some "spark" until it's screw completely... But now nothing... 12v on my meter... But...

  6. #6
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472

    Cool

    Battery for sure.
    Get a new 1 before you ride because they dump out at the worst times when your out riding....

  7. #7
    +1 on the battery. Read this and get an AGM:

    http://www.greenhulk.net/forums/showthread.php?t=209204

  8. #8
    Impulses's Avatar
    Join Date
    Dec 2011
    Location
    europe
    Posts
    822
    +1
    27
    send a video with your problem so it will be easier diagnosis

  9. #9
    spouk3's Avatar
    Join Date
    Mar 2012
    Location
    Montreal, QC, Canada
    Posts
    635
    +1
    30
    Yup, that's what I'll do... Let me try to charge it first... If it's not starting... I'll post a video on YouTube and share it here

  10. #10
    spouk3's Avatar
    Join Date
    Mar 2012
    Location
    Montreal, QC, Canada
    Posts
    635
    +1
    30
    Ok, was an empty battery... After a charge.... It started on the first push and AFR idle is at 14.2... I think I need to increase the fuel pressure a bit...

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Jet Ski won't start
    By Lenn1562 in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 06-25-2010, 06:28 PM
  2. Ski won't start and throwing a code
    By Zach07RXP in forum 4-Tec Performance
    Replies: 10
    Last Post: 08-19-2009, 12:03 PM
  3. Ski won't start
    By rathee in forum Kawasaki PWC Performance (4-stroke)
    Replies: 15
    Last Post: 08-21-2008, 04:45 PM
  4. Ski won't start!
    By Hockey369 in forum Yamaha Old School Skis
    Replies: 21
    Last Post: 11-19-2007, 08:31 AM
  5. Ski won't start...
    By Yellow93 in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 05-30-2006, 11:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •