Results 1 to 5 of 5
  1. #1
    Mighty Mouse's Avatar
    Join Date
    Feb 2011
    Location
    Mississippi
    Posts
    876
    +1
    23

    RFI MPEM Starter timer?

    I am trying to resurrect an old 99 GTX RFI with 787 engine. Bought not running. Had to put in a new crank. New battery. No beep on the key, but I do get a beep, fuel pump comes on for a brief moment when I press start button. No power to starter side of the solenoid. Checked the switch of the solenoid, but my meter would read voltage on the positive side. It changes voltage but shuts off even when I hold the start button down. Does the MPEM have a time and shuts voltage to the solenoid after a few seconds if it doesn't sense an engine turning over? I need to get an old analog VOM and see if the needle will swing.
    I am trying to test to see if I get voltage from the MPEM.

    Gauge does not come on. I suspect it is broken. I've had solenoid click a few times, but cant get it to repeat. New battery... charged and shows 12.8v.


  2. #2
    Cliff's Avatar
    Join Date
    Jan 2006
    Location
    Middle Tennessee
    Posts
    207
    +1
    24
    It sounds like the MPEM is not recognizing the Lanyard. Either the DESS post is bad or you have the wrong Lanyard.

  3. #3
    wkuadam07's Avatar
    Join Date
    Feb 2013
    Location
    Bowling Green, KY
    Posts
    1,377
    +1
    162
    No beep on the key means that there is either a bad Dess Post, or faulty wiring on the way to it. You have some type of activity, so there is good signs that the MPEM is OK. It should beep 2 times when the dess is working and the key is correct. If it's the wrong key then you should get one long beep on the key.

  4. #4
    Check the dess post... Black wire to black/yellow from the dess post, should be closed circuit when the key is on the post.

  5. #5
    Mighty Mouse's Avatar
    Join Date
    Feb 2011
    Location
    Mississippi
    Posts
    876
    +1
    23
    OK. Replaced beeper and now get the 2 beeps. Also found the solenoid was bad. When I replaced it, it now gives a constant 12 volts for as long as the button is pushed. So you answer my own question, No there is not a timer built into the MPEM if you hold the start button down. Thanks for the help. No on to rebuilding the starter as I now get 12 volts out the starter side of the solenoid, but no starter engaging. This thing is starting to put me in the negative side of break even. HA!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2003 seadoo gti le rfi mpem timer function
    By redlinepower in forum 2-Stroke Performance
    Replies: 1
    Last Post: 06-13-2012, 11:53 AM
  2. WTB - Parts 99 gtx rfi mpem
    By shooter98xpl in forum Sea Doo 2 Stroke Skis
    Replies: 0
    Last Post: 05-17-2012, 07:16 PM
  3. FS 2002 gtx rfi mpem
    By xsmitty in forum Sea Doo 2 Stroke Skis
    Replies: 0
    Last Post: 09-13-2011, 12:10 AM
  4. WTB 1999 GSX RFI MPEM needed!!! Help please
    By tocullo in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 05-03-2011, 07:42 PM
  5. Wanted-gtx rfi mpem
    By porschemaniac in forum 2-Stroke Performance
    Replies: 1
    Last Post: 09-02-2009, 09:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •