Results 1 to 8 of 8
  1. #1
    RGUN's Avatar
    Join Date
    Aug 2013
    Location
    Work: GTA ------------ ----------------- Play: Georgian Bay
    Posts
    551
    +1
    53

    Cruise Control Behaviour Question

    I installed cruise control on my 2012 RXPX last year and while I am happy with the function for the most part, there are a few aspects that I find borderline dangerous. I spent some time talking with the Sea-Doo reps at the Toronto Boat Show and they thought it was atypical, so asked me to complain to Sea-Doo to get a replacement authorized. Before I do that and not solve my issues, I'd appreciate feedback if you use cruise control and do, or do not experience similar behaviour.

    Behaviour 1 (infrequent, probably once every 2 hours of cruise use) - Cruise will function normally, speed will then begin to drop below set point. Speed will drop significantly below set point. PWC will then accelerate at full throttle back to set point. As an example, I will be riding at 35mph, it will slow to 32, 30, 28, 25 then suddenly accelerate at full throttle back to 35mph. I find this particularly dangerous because I ride 95% with a passenger, and any full throttle accelerate, especially during a long ride, really needs to be preceded by a warning.

    Behaviour 2 (constant) - Cruise removes all ability to modulate the throttle. When under cruise, you hold the throttle wide open, any acceleration it does do is full throttle, which makes cruise in severe chop interesting. If you are using cruise, and you slow down for any reason, you can't easily ramp back up to cruise speed. The first 15/16ths of throttle travel does nothing (literally, you may as well have your hand off the throttle). The entire spectrum of throttle positions is now within that final 1/16th of throttle movement. It is impossible to get back up to speed in a smooth fashion.

    I would love to hear from everyone else regarding their experience with cruise and if they experience similar issues. I would love to have the system replaced on mine if it will fix my issues, but I don't necessarily want my Sea-Doo to be in the dealer for 2 weeks during the summer to fix this if it is in fact normal behaviour.

    Feedback appreciated, thanks.


  2. #2
    interesting. Im considering adding this and would like to know

    also you can be brief as not to derail your thread but how is the depth sounder?

  3. #3
    spouk3's Avatar
    Join Date
    Mar 2012
    Location
    Montreal, QC, Canada
    Posts
    635
    +1
    30
    Humm... Never experience the #1 except if I loose GPS signal under bridge sometimes it accelerate suddenly... For the #2, from what I remember, I can slowly accelerate to my cruise speed... Is your rxp stock?

  4. #4
    RGUN's Avatar
    Join Date
    Aug 2013
    Location
    Work: GTA ------------ ----------------- Play: Georgian Bay
    Posts
    551
    +1
    53
    interesting. Im considering adding this and would like to know

    also you can be brief as not to derail your thread but how is the depth sounder?
    I have not had any seat time yet since the depth sounder installation


    Humm... Never experience the #1 except if I loose GPS signal under bridge sometimes it accelerate suddenly... For the #2, from what I remember, I can slowly accelerate to my cruise speed... Is your rxp stock?
    So you do experience #1 but only in circumstances when you've lost GPS signal? or is it not a similar behaviour. Yes mine is stock.

  5. #5
    spouk3's Avatar
    Join Date
    Mar 2012
    Location
    Montreal, QC, Canada
    Posts
    635
    +1
    30
    Only when GPS signal is lost... I use the cruise control a lot during the summer during long ride... And never had what you describe... Except the GPS lost...

  6. #6
    idoodou's Avatar
    Join Date
    Mar 2009
    Location
    cincy,ohio
    Posts
    765
    +1
    30
    do you know you can use the up and down arrow buttons to change speed while in cruise

  7. #7
    RGUN's Avatar
    Join Date
    Aug 2013
    Location
    Work: GTA ------------ ----------------- Play: Georgian Bay
    Posts
    551
    +1
    53
    Quote Originally Posted by idoodou View Post
    do you know you can use the up and down arrow buttons to change speed while in cruise
    I do, are you proposing this as a solution to problem 2 or thinking something else? Do you have cruise control, and if so have you ever experienced similar issues?

  8. #8
    idoodou's Avatar
    Join Date
    Mar 2009
    Location
    cincy,ohio
    Posts
    765
    +1
    30
    i have cruise but never had that problem has been great for me

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Some questions about my 2013 fx sho - warning lamp, cruise control
    By Titanup16 in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 09-23-2016, 10:30 PM
  2. Cant get Cruise control to work-Candoo questions
    By UNSANE in forum Sea Doo ECU Support
    Replies: 7
    Last Post: 03-31-2015, 08:56 AM
  3. 2007 FX Cruiser HO and adding Cruise control question
    By Frankj9000 in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 06-18-2013, 06:42 PM
  4. Replies: 10
    Last Post: 09-27-2011, 08:59 PM
  5. Question on SHO cruise control question..
    By skeeterzx225 in forum Yamaha PWC Performance (4-stroke)
    Replies: 2
    Last Post: 07-16-2008, 04:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •