Results 1 to 7 of 7

Thread: Prop question

  1. #1

    Prop question

    Can someone explain the advantages or otherwise of a 14/21 solas over stock on a 12 model 300x. Basically stock with delimiter and revs to approx 7900.


  2. #2
    "just sayin".. jetdave56's Avatar
    Join Date
    Nov 2008
    Location
    JERSEY SHORE
    Posts
    4,502
    +1
    619
    I assume it's similar to the 2011..the ski will drop rpms to 7750 -7850 with a 14/21 in the summer it will give you more torque on the water so more of a Accel feel from holeshot to top speed .. But overall the difference is minimal...

    Others here just prefer the stock prop , higher speed some claim...

    I never tested stock prop with a delimiter so never tested top speed...

  3. #3
    Moderator #985 lasportsmn's Avatar
    Join Date
    Oct 2008
    Location
    Pierre Part, Louisiana
    Posts
    4,780
    +1
    358
    It is mostly due to price. The oem impeller can handle a ski with only the SCOM just fine. Once we begin modifying the ski further the Solas shows it's advantages by removing the cavitation. I am sure there will be some reports coming when available but I am thinking that the 310 impeller may be an option also.
    Time will tell.

  4. #4
    Quote Originally Posted by jetdave56 View Post
    I assume it's similar to the 2011..the ski will drop rpms to 7750 -7850 with a 14/21 in the summer it will give you more torque on the water so more of a Accel feel from holeshot to top speed .. But overall the difference is minimal...

    Others here just prefer the stock prop , higher speed some claim...

    I never tested stock prop with a delimiter so never tested top speed...
    Sorry, should have said it has the 14/21 in now but am getting close to needing to be replaced.

  5. #5
    Gentlemen,

    We "Guinea-pigged" & tried the 310 impeller on the 2011 300X and had some issues - not sure if it was due to what appears to be a differently configured snout on the 310X impeller relative to the 300X, regardless it appeared to have some binding after installation and while running under load - removed it. Bottom line it did not appear compatible. Interested if anyone has had a different result...?

  6. +1 by:


  7. #6
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    interesting test mark, parts do show a different part number on the 300 vs 310 shaft so something has slightly changed? everything else including the vane is the same, so maybe different length shaft or shape of rear of the prop?

  8. #7
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Brisvegas
    Posts
    4,165
    +1
    602
    Different setback

  9. +1 by:


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. solas prop question
    By Top banana in forum 4-Tec Performance
    Replies: 0
    Last Post: 09-27-2006, 12:12 AM
  2. RXT prop questions
    By Mark S in forum 4-Tec Performance
    Replies: 12
    Last Post: 09-23-2006, 09:35 AM
  3. Procedure to initialize RR ECU and Prop question
    By bankyf in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-26-2006, 05:16 PM
  4. Wear ring & prop question
    By Carlos Miami RXP in forum 4-Tec Performance
    Replies: 11
    Last Post: 03-21-2006, 11:55 PM
  5. Fins Damaged Ahead of Prop Question
    By Sirhc7897 in forum 4-Tec Performance
    Replies: 14
    Last Post: 02-22-2006, 11:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •