Results 1 to 2 of 2
  1. #1

    Kawasaki zxi1100

    Hi all I just rebuilt my carbs completely tryed to run the ski but sees to be fuel starved I have the cdk 2 carbs the accelerator pumps not squirting fuel either
    I have put a air line in the return and seen fuel run from the return outlet then it starts and runs for few seconds at low revs or runs ok at higher revs

    could this be a pop off issue or am I completely wrong

    cheers in advance

  2. #2
    Banned User
    Join Date
    Jun 2010
    Milwaukee WI
    The accel pump will prime itself while the engine is running. If you want to manually prime it, push the plunger down on the pump and hold it in for a few seconds with the engine running. It should get the pump primed.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS - Parts 1999 Kawasaki ZXi1100 Parting Out
    By quadridermx in forum Kawasaki Classifieds
    Replies: 0
    Last Post: 07-19-2013, 09:31 AM
  2. kawasaki zxi1100 not starting even when warm
    By rockcock in forum Kawasaki Open Discussion
    Replies: 10
    Last Post: 07-26-2011, 06:56 PM
  3. FS Kawasaki ZXI1100 core crank
    By Quad411 in forum Kawasaki Classifieds
    Replies: 0
    Last Post: 12-01-2008, 01:04 PM
  4. 06 Kawasaki pictures's
    By Enufpwr in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 09-16-2005, 10:02 PM
  5. You have seen the 2006 Kawasaki lineup...
    By 11 in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 09-10-2005, 10:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts