Results 1 to 8 of 8
  1. #1
    kaiser's Avatar
    Join Date
    Jan 2008
    Location
    western pa.
    Posts
    133
    +1
    5

    has anybody come across this

    Looking over the new ski and felt a roughness under the back end of the ride plate where its concave,upon closer inspection saw that it was cracks looks like a bad casting never should have made it past QC somebody just said fuck it.The cracks don't penetrate to the other side but maybe someday.


  2. #2
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Brisvegas
    Posts
    4,157
    +1
    598
    its nothing.............there NOT cracks

    on the 310 they have actually sanded it 90% smooth ,

    its nothing to do with QC , because thats how they ALL are, they just didnt want to smooth finish it

    its all in the SEARCH function even all the pictures of exactly what you are talking about..

    Dont worry about it just ride it, if you want to fix it , its about a 5min job with a sander

    Just get out and ride it before you complain about something DIFFERENT I say ....action of this ski speak volume, even with the ugly casting MARKS

    Waz

  3. #3
    kaiser's Avatar
    Join Date
    Jan 2008
    Location
    western pa.
    Posts
    133
    +1
    5
    They are cracks 16th deep and 32nd wide not stress cracks but casting cracks like the metal did not flow 100% maybe like the casting sand was traped in some areas.I know after market ride plates dont look that way.

  4. #4
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Brisvegas
    Posts
    4,157
    +1
    598
    A crack is a fault.....
    you have a casting MARK ..............As I said above sand them smooth and forget about it



    it WILL not affect anything on the beast

    Waz

  5. #5
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    Yep just a casting flow mark, not a fault,crack or flaw. Sand it and they are gone.

  6. #6
    kaiser's Avatar
    Join Date
    Jan 2008
    Location
    western pa.
    Posts
    133
    +1
    5

    Question cracks

    Click image for larger version. 

Name:	2891422339_ORIG.jpg 
Views:	41 
Size:	58.8 KB 
ID:	322354Click image for larger version. 

Name:	2891422107_ORIG.jpg 
Views:	40 
Size:	69.6 KB 
ID:	322355
    Quote Originally Posted by nicjak View Post
    Yep just a casting flow mark, not a fault,crack or flaw. Sand it and they are gone.
    Is this what others have seen?

  7. #7
    Pain is fear leaving your body.... rlovebk's Avatar
    Join Date
    Aug 2008
    Location
    So. Cal.
    Posts
    5,206
    +1
    511
    Yep. Just poor casting/finish.
    You can clean it up as much as you want or not.
    It will not "Fail" on you so safety not an issue.

  8. #8
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Brisvegas
    Posts
    4,157
    +1
    598
    Yep....marks
    Not cracks I promise u....every ultra I have had since 2007 have looked the same

    Waz

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. has anybody experience this
    By kawifan in forum Yamaha PWC Performance (4-stroke)
    Replies: 2
    Last Post: 06-08-2011, 05:05 PM
  2. Replies: 2
    Last Post: 04-27-2011, 08:46 AM
  3. Has anybody had problems with pump bolts coming loose?
    By MPower in forum 4-Tec Performance
    Replies: 19
    Last Post: 02-22-2009, 01:21 PM
  4. has anyone come across this?
    By jetskibill9999 in forum 4-Tec Performance
    Replies: 27
    Last Post: 09-10-2008, 08:10 PM
  5. Has anybody seen this video? turbo rxp
    By bling_bling_420 in forum Videos & Pictures
    Replies: 2
    Last Post: 08-15-2007, 07:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •