Results 1 to 2 of 2
  1. #1

    04 RXP VTS dont work

    2004 RXP... VTS dont work, Motor Good & runs if you reverse the motor wires. the VTS switch will Only motor down hooked to the Module. Has anyone fixed there ski with the VTS Module Quick Fix Harness?? OR is it Best just to buy a New Module from seadoo?? Looks like 1 limit switch is broken from the test that have been Performed on the module..... & yes the booth was a problem but all of that has been corrected with a new motor. But it appears the water killed the module too.
    Last edited by joe w; 02-02-2014 at 12:02 AM. Reason: updated


  2. #2
    AtoMIC_OraNGE greenbullet's Avatar
    Join Date
    Jul 2010
    Location
    Barrie / BuckHORN Ontario
    Posts
    2,509
    +1
    234
    Check the harness plug that normally is laying in the hull.... might have come unsnapped or corroded before you replace it if there is water damage... test the vts plug to see if you get power when you pulse the blue and green wire up or down

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 5
    Last Post: 10-08-2014, 04:59 PM
  2. 04 RXP VTS digital display mark vanishes?!?!
    By COBRA445 in forum 4-Tec Performance
    Replies: 6
    Last Post: 07-29-2013, 11:33 PM
  3. Replies: 1
    Last Post: 02-12-2012, 08:58 PM
  4. FS 04 rxp vts for sale
    By abarrassr07 in forum Sea Doo Classifieds
    Replies: 5
    Last Post: 02-10-2010, 06:48 PM
  5. 04 RXP - Leak into Hull thru VTS
    By joeg in forum 4-Tec Performance
    Replies: 7
    Last Post: 07-01-2005, 02:21 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •