Results 1 to 9 of 9
  1. #1
    SeaDoocer
    Guest

    It's up and running!! Check it out!! Go AWA!!!

    Finally!!! phoenixwatercraftclub.com


  2. #2
    JAG's Avatar
    Join Date
    Feb 2006
    Location
    Richmond, VA
    Posts
    1,026
    Quote Originally Posted by SeaDoocer View Post
    Finally!!! phoenixwatercraftclub.com
    That's top shelf bro! Very nice!

    Except for the ugly members you have pics posted of...gosh...where did you come up with such ugly members????

  3. #3
    jimboman's Avatar
    Join Date
    Feb 2007
    Location
    Austin, TX
    Posts
    103
    Sweet website. Nicely done.

  4. #4
    I'm kind of a big deal SeanCucf's Avatar
    Join Date
    Jul 2006
    Location
    Oldsmar, FL
    Posts
    1,852
    no love for the GH or 4tec performance??????



    nice site...pics are kinda small though, don't you think?

  5. #5
    V-Tec, 4-Tech that's how I roll meirvin's Avatar
    Join Date
    Feb 2006
    Location
    Dallas/Ft Worth, Tx
    Posts
    1,514
    +1
    3
    the learn more and more news buttons dont work for me

  6. #6
    SeaDoocer
    Guest
    Quote Originally Posted by SeanCucf View Post
    no love for the GH or 4tec performance??????



    nice site...pics are kinda small though, don't you think?

    Hey, don't knock the photo gallery!
    Yea, they are a bit small but that will change next month. It cost some bucks to get this up and some of it is just shell for the time being...it will get better but I needed to go with what we could in order to get our advertisers on board soon.
    JAG, thanks for the pics..when I upgraded to Vista from XP I lost a lot of our own personal pics from previous rides. I didn't know you would be plastered on the front though...hehe...really hope you didn't mind. I was desperate! lol

  7. #7
    JAG's Avatar
    Join Date
    Feb 2006
    Location
    Richmond, VA
    Posts
    1,026
    Hey bro! I don't mind at all...just thought you'd put up some better looking faces...lol!

  8. #8
    I'm kind of a big deal SeanCucf's Avatar
    Join Date
    Jul 2006
    Location
    Oldsmar, FL
    Posts
    1,852
    hey...not knockin it.....but, you wanted feedback, right?

  9. #9
    SeaDoocer
    Guest
    Yes, but..no! Lol
    It's all good.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: 05-24-2012, 05:46 PM
  2. Won't start up and run..
    By Carson in forum Polaris Open Discussion
    Replies: 24
    Last Post: 09-01-2011, 09:51 PM
  3. GH Back up and running
    By Jrsrxp in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 06-02-2008, 09:37 AM
  4. ECU up and running on RXP
    By Jrsrxp in forum 4-Tec Performance
    Replies: 15
    Last Post: 04-16-2006, 12:23 AM
  5. Triple back up and running
    By GPRPITMAN in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 01-14-2006, 04:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •