Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 27
  1. #1
    Tas_RXP's Avatar
    Join Date
    May 2005
    Location
    Melbourne Australia
    Posts
    44

    2009 GTX255 iS coughing and spluttering

    Hi guys need your help. I have a 2009 GTX iS that has a very rough idle and is coughing and splattering and backfiring at idle. Throttle doesn't respond down low but works after a while above 5000rpm. So far I have replaced coils, plugs, throttle body, ECU, injectors, fuel baffle, and TOPS sensor. Buds is not reporting any error codes. Can anyone share any suggestions to what could be the problem or what to test next.


  2. #2
    Snapping_turtle's Avatar
    Join Date
    Jan 2014
    Location
    Queensland, Australia
    Posts
    41
    +1
    2
    It does sound electrical but have you done your basics? Checked compressions, supercharger, inter cooler? How old is your fuel??

  3. #3
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,991
    +1
    455
    Reset your throttle body and report back

  4. #4
    Tas_RXP's Avatar
    Join Date
    May 2005
    Location
    Melbourne Australia
    Posts
    44
    Quote Originally Posted by Snapping_turtle View Post
    It does sound electrical but have you done your basics? Checked compressions, supercharger, inter cooler? How old is your fuel??
    Sorry forgot to mention did a compression test, supercharger ok, and new fuel as well. Did an ohms and continuity test on everything I can and all to spec. This is really driving me mad.

  5. #5
    Tas_RXP's Avatar
    Join Date
    May 2005
    Location
    Melbourne Australia
    Posts
    44
    Throttle body reset and still no change. I sprayed some CRC straight into the throttle body and ski fired up. Spark plugs are badly fouled. Replaced them and still no go.

  6. #6
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,037
    +1
    672
    fuel pump is not getting enough pressure to atomize the fuel and is soaking the plugs or the coil packs are not firing the plugs. Cam sensor could also be relaying misinformation causing misfiring

  7. #7
    Tiny's Avatar
    Join Date
    Sep 2006
    Location
    The Atl
    Posts
    3,561
    +1
    578
    Did you take a fuel sample and check it for debris or water????

  8. #8
    Tas_RXP's Avatar
    Join Date
    May 2005
    Location
    Melbourne Australia
    Posts
    44
    Quote Originally Posted by imp0ster View Post
    fuel pump is not getting enough pressure to atomize the fuel and is soaking the plugs or the coil packs are not firing the plugs. Cam sensor could also be relaying misinformation causing misfiring
    Haven't been able to test fuel pressure but measured the fuel from each injector and it was identical on all three injectors. Coils were replaced and sparking up okay. Haven't checked the Cam sensor. Will try that tonight.

  9. #9
    Tas_RXP's Avatar
    Join Date
    May 2005
    Location
    Melbourne Australia
    Posts
    44
    Quote Originally Posted by Tiny View Post
    Did you take a fuel sample and check it for debris or water????
    Hi Tiny, took a sample and clear of any debri. There was only one bar of fuel in the ski and toped it up with 42 liters of fresh fuel just to be sure.

  10. #10
    brendanm's Avatar
    Join Date
    Jan 2013
    Location
    Gold Coast, Australia
    Posts
    738
    +1
    149
    Check the fuel pressure.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2009 RXT iS 255 and newer iBR actuator/motor problems solutions
    By HydroWarfare in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-23-2016, 07:16 AM
  2. 2009 RXT IS IBR and driveshaft problems
    By Corn in forum 4-Tec Performance
    Replies: 14
    Last Post: 08-06-2015, 12:22 PM
  3. 99 XPLTD coughing and spluttering at 3000-5000 rpm
    By Aussielyons in forum 2-Stroke Performance
    Replies: 6
    Last Post: 05-15-2013, 03:46 PM
  4. Now this is speed and performance...
    By Fast-XPL in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 08-23-2005, 10:27 AM
  5. thinking of Selling my RXP. Wife is pregnant and due March
    By Water4fire in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 08-07-2005, 07:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •