Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 40
  1. #1
    jumpman's Avatar
    Join Date
    Feb 2014
    Location
    Puerto Rico
    Posts
    213
    +1
    5

    Help needed with my new SeaDoo

    Hi guys;
    I recently bought a 2011 RXT-X 260 RS and I'm completely new to the PWC world. I will appreciate any help on the cleaning topic. I know how to make a flush, but have serious doubts on how to clean my engine and the inside part of the hull. Should I spray water over the engine or just around it? I bought Salt-Away, Film Fluid and Fogging oil as a recommendation, but have some doubts of where to use each one. Should I spray film fluid over everything including hoses, battery and everything inside? What about the fogging oil? Any help will be greatly appreciated because I want to take the best care possible of my SeaDoo.


  2. #2
    Primary Language: Sarcasm Pony Racer's Avatar
    Join Date
    Jun 2011
    Location
    RiverShit, Ct
    Posts
    480
    +1
    28
    I don't know about others but here is what I do 2x3 times a season..

    prior to leaving for the boat ramp..
    pour about a cup of dish detergent or laundry detergent in the hull..
    fill the hull up with water to approx. the bottom of the charger..
    drive the ski on the trailer full of water to about a mile before the ramp ( for me its approx. 15 mile trip)

    remove the drain plugs and let all the water out.. ( if you have a bilge pump turn it on as well)..

    after all the water is out.. put plugs back in, drop ski in water..

  3. #3
    jumpman's Avatar
    Join Date
    Feb 2014
    Location
    Puerto Rico
    Posts
    213
    +1
    5
    Thanks a lot for your info. So I should spray all, including the engine? This wont be dangerous? I should spay the XPS (fluid film in my case) over everything including engine, hoses, EVERYTHING?

  4. #4
    jumpman's Avatar
    Join Date
    Feb 2014
    Location
    Puerto Rico
    Posts
    213
    +1
    5
    Thanks, I heard some great post about Fluid Film, but Going to give XPS a try. My mane concern was about spraying water over the engine, since some say it's not recommend while other say it is.

  5. #5
    jumpman's Avatar
    Join Date
    Feb 2014
    Location
    Puerto Rico
    Posts
    213
    +1
    5
    Ok, talking about something different now. I found that my coolant bottle has two black hoses that are connected properly, but it has another one that is transparent that it's just sitting there connected to nothing. It's supposed to be attach to something or it's just a breather?Click image for larger version. 

Name:	20140207_163506.jpg 
Views:	74 
Size:	80.8 KB 
ID:	322745

  6. #6
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472

    Cool

    The clear hose is a over flow hose and is not suppose to be connected.

    On a topic of reliability has your inner cooler been changed out?
    Stock i/c are a known weak link and when they crap out they can ruin alot of major components including your motor...

    Welcome aboard the Hulk!!!!

  7. #7
    jumpman's Avatar
    Join Date
    Feb 2014
    Location
    Puerto Rico
    Posts
    213
    +1
    5
    Thanks wotxxxsd. Yes, my intercooler was change by the previous owner because water it was faulty and water got all the way to the pistons and they even change the engine block. It's working pretty well now, hope it continue that way. Can I ask you something else? I'm really new to all PWC things and I also saw that there are two big hose all the way in the front of my seadoo and I don't know if they should be attach to something. If you could help me I will really appreciated. Thanks.Click image for larger version. 

Name:	20140210_121957.jpg 
Views:	71 
Size:	109.5 KB 
ID:	322746


    Also All the way to the back near the reverse engine there are some hose connected, but is still a plug with nothing in it. Is there supposed to be something there?Click image for larger version. 

Name:	20140208_181642.jpg 
Views:	75 
Size:	111.4 KB 
ID:	322747

  8. #8
    jumpman's Avatar
    Join Date
    Feb 2014
    Location
    Puerto Rico
    Posts
    213
    +1
    5
    Thanks for your help.

  9. #9
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    Cant help you on the bottom pic as I know less about Seadoo than you doo...lol

    The black hoses are vent hoses to allow air in to the hull and not allow water into the hull in case you roll the ski upside down....these hoses are common on all skis....

  10. #10
    jumpman's Avatar
    Join Date
    Feb 2014
    Location
    Puerto Rico
    Posts
    213
    +1
    5
    Thanks to all. I haven't try the seadoo in the water yet. Hope to do it soon. I just want to make sure everything is working properly before I do. I notice that there is some sand in the bottom of the hull, don't know if this is normal or if there was some kind of problem with the previous owner that leas to that. Is not much , but still there is a little bit of it. What do you guys think?

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need help with my (NEW to me) Wave raider 1100
    By needforspeed in forum Yamaha Old School Skis
    Replies: 5
    Last Post: 05-28-2015, 01:00 PM
  2. need help with my 1998 seadoo speedster twin 787's
    By biggs101 in forum Sea Doo Sport Boats
    Replies: 6
    Last Post: 01-28-2013, 04:29 AM
  3. need help with my 96 seadoo xp's im stumped!
    By brandon32689 in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 05-28-2011, 07:21 PM
  4. Help needed with my PRO 785
    By kcoleman10 in forum Polaris Open Discussion
    Replies: 0
    Last Post: 04-22-2008, 07:04 AM
  5. Can anyone help me with my impeller shaft and new prop?
    By ccassone in forum 2-Stroke Performance
    Replies: 0
    Last Post: 02-10-2006, 03:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •