Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1
    jumpman's Avatar
    Join Date
    Feb 2014
    Location
    Puerto Rico
    Posts
    213
    +1
    5

    Anybody else with this in there 2011 RXT-X 260 RS?

    Hi:
    As I said before I'm relatively new to the PWC world and I'm trying to learn as much as possible here. My Seadoo has a little water exit on the back of it and by the way it looks I'm guessing it was done by the previous owner (which I don't have communication anymore because he moved away) because I don't think I've seen this in other 2011 models. I'm posting picture of what it looks like on the outside. In the inside it has a hose that goes from the intercooler right to what you see in the picture (intercooler was change by warranty because 2011 comes with problems). Everytime I start my seadoo water come out of it.
    Click image for larger version. 

Name:	20140213_163657.jpg 
Views:	290 
Size:	55.2 KB 
ID:	323089Click image for larger version. 

Name:	20140213_163708(0).jpg 
Views:	177 
Size:	40.8 KB 
ID:	323090


  2. #2
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    That's not from the factory..

  3. #3
    jumpman's Avatar
    Join Date
    Feb 2014
    Location
    Puerto Rico
    Posts
    213
    +1
    5
    Any guess? I believe it was made by the dealer when they change the intercooler, but don't know why. As I said before there's a hose that goes from the intercooler to that exit shooting water outside all the time.

  4. #4
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Sounds like something was added to flush the inner cooler.. if so thats good news..

  5. #5
    jumpman's Avatar
    Join Date
    Feb 2014
    Location
    Puerto Rico
    Posts
    213
    +1
    5
    Hey wotxxxsd you got me worried all day thinking about the carbon seal topic we talk about this morning. I hope not but if the carbon seal is bad the hull will get water right away or it could take a while for it to happen before I realized? Once again sorry for so many questions, but I'm just trying to learn as much as I can on a topic I know very little of.

  6. #6
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    I don't think you need to worry about it. I really was just letting you know that 4 min is way too long to flush a doooo..

    Like i said in your other threads I've seen doos flushed for a lot longer with no issues.
    It's just not good to flush for more than 1-2 min.
    And since you have a flush line on your i/c yours flushes better anyways...
    Remember all your flushing is the exhaust and the i/c.
    Doos are all closed loop cooling so no salt water ever runs thru the motor..

  7. #7
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    3,851
    +1
    742
    Sounds like the bleeder line from the IC. It's purpose is to completely fill the IC with water instead of having a block at the top of the IC with air. On the stock 2010 it is in front of the iBr, next to the line that comes from the pump into the hull, which is very hard to access, maybe he just relocated it.

  8. #8
    Its has had the upgraded cooler fitted. Pm me the hin number and I can confirm this.

    The pisser is the cooler upgrade. Poorly fitted with white sealant. Also check the part number on the cooler. You want it to end in 332 not the early 319

  9. #9
    jumpman's Avatar
    Join Date
    Feb 2014
    Location
    Puerto Rico
    Posts
    213
    +1
    5
    Would I be able to see the number without having to get the thing out? I'll check it later when I get home and let you know. Thanks.

  10. #10
    Q in Arizona's Avatar
    Join Date
    May 2013
    Location
    Phoenix, Az
    Posts
    30,576
    +1
    7,355
    Quote Originally Posted by jumpman View Post
    Hey wotxxxsd you got me worried all day thinking about the carbon seal topic we talk about this morning.
    2 words for you...bilge pump. <---install one.

  11. +1 by:


Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. XPS Lubricant or Fluid Film for my 2011 RXT-X 260 RS???
    By jumpman in forum Sea Doo Open Discussion
    Replies: 24
    Last Post: 06-26-2014, 06:28 PM
  2. Anybody knows if this fits a 2011 RXT-X 260 RS????
    By jumpman in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 02-21-2014, 09:16 PM
  3. Best location to install a bilge pump on 2011 RXT-X 260 RS????
    By jumpman in forum Sea Doo Open Discussion
    Replies: 13
    Last Post: 02-15-2014, 01:00 PM
  4. Dilemma on how to flush my 2011 RXT-X 260 RS
    By jumpman in forum Sea Doo Open Discussion
    Replies: 21
    Last Post: 02-14-2014, 07:17 AM
  5. 2011 RXT-X 260 RS runs too lean?
    By HSCOOL in forum 4-Tec Performance
    Replies: 23
    Last Post: 08-08-2013, 10:57 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •