Results 1 to 5 of 5

Thread: SIFB in MSX 110

  1. #1

    SIFB in MSX 110

    Hi there,

    Does anyone knows where is the SIFB located in the MSX110?

    Best Regards,

    NC


  2. #2
    ripcuda's Avatar
    Join Date
    May 2010
    Location
    Newman Lake, WA
    Posts
    2,389
    +1
    166
    Welcome!

    The System Interface box (SIFB) on the MSX 110 and 150 is located above the battery... rear right side... plugged into the wire harness that goes up to the brown box main relay above the battery. It's a 3"-ish square thing with the plug right in the middle. Should say System IFB on it.

    Cheers!

  3. #3
    Hi there,

    My Jet was stored for long time and the battery went dead, so to start the engine I put the cables connected to my car battery and started fine!

    Then when I wanted to shut it down, nothing happened! neither removing the lanyard or the stop button...

    So, I have read that the SIFB may be damaged...

    My question is: is it probable that the high Amps of the battery car damaged this part?

    Best Regards,

    NC

  4. #4
    Banned User
    Join Date
    Mar 2013
    Posts
    73
    1
    Last edited by chc3; 01-12-2015 at 10:26 PM.

  5. #5
    ripcuda's Avatar
    Join Date
    May 2010
    Location
    Newman Lake, WA
    Posts
    2,389
    +1
    166
    Yeah... jumping a jet ski battery is not recommended. I've done it... but never off a running car. I just have extra batteries around the shop that I'll piggy-back onto the suspected low battery. I've never fried anything electrical doing this... so (knock on wood)... but I can't recommend it.

    But jumping off a running car... I've heard that's a recipe for trouble with the higher amps and such.

    Did that cause your trouble with the possibly fried SIFB? Maybe... I'd rule out the stop switch... but yeah... the SIFB would be the next culprit.

    Cheers!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB SIFB msx 110 interface needed
    By rxpdz in forum Polaris Classifieds
    Replies: 1
    Last Post: 05-17-2011, 05:16 PM
  2. MSX 110 Stuck in Idle Mode
    By bamasnow in forum MSX/Matrix
    Replies: 3
    Last Post: 04-08-2011, 05:34 PM
  3. WTB MSX 110/150 with blown motor in Northeast
    By raylesk in forum Polaris Classifieds
    Replies: 1
    Last Post: 04-13-2010, 12:20 PM
  4. Fault codes in a 2004 msx 110
    By gvnitup in forum MSX/Matrix
    Replies: 1
    Last Post: 09-22-2009, 06:14 AM
  5. 04 msx 110 water in oil problem & noises
    By alt in forum MSX/Matrix
    Replies: 6
    Last Post: 06-20-2008, 07:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •