Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 41
  1. #1

    Join Date
    May 2011
    Location
    Newcastle Australia
    Posts
    72
    +1
    1

    Can't get over 8180rpm

    Hi guys just trying to see if you can advise what I should be checking to work out why I am not gaining any more revs with mods

    2013 260 rxpx rs with a 8600 tune + retainers + 15/19r = 8160-8180 rpm @ 75mph on the dash

    The above with standard airbox mod =8160-8180 rpm @ 75mph on the dash

    The above removing the flame arrestor = 8140-8180 rpm @ 74-75mph on the dash

    Added a gen 3 cooler + riva intercooler pipes + 4 inch kanaflex and you guessed it = 8140-8180 rpm @ 74-75mph on the dash

    The ski does not feel and stronger after any mod,
    (75 mph on the dash is about 73mph on the GPS)

    one thing to note is that the ski will only go to 8040rpm for the first 10 mins after it starts then it allows it to creep up to the 8140-8180, it does it every ride

    the tune is from a seadoo dealer,
    wear ring is new
    ski has 17 hours on it now and serviced 3 hours ago when the tune was done

    I'm thinking : tune has the wrong limiter on it
    Prop isn't actually a 15/19 however this doesn't explain why revs haven't moved with mods
    Air intake sensor is out of wack and the computer is pulling timing or revs

    If you have any other ideas I would love to hear it!

    cheers


  2. #2
    dpracing's Avatar
    Join Date
    Jan 2008
    Location
    Palm Beach, Florida
    Posts
    1,244
    +1
    246
    What are your AFR's?

    who's tune is it?

  3. #3
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    3,849
    +1
    742
    Sounds like stock ECU tuning to me!

    What injectors are you using? stock are 48#

    Supercharger? stock or something else?

    Need more details about this "dealer installed tune"…...

  4. +1 by:


  5. #4

    Join Date
    May 2011
    Location
    Newcastle Australia
    Posts
    72
    +1
    1
    The tune was done by a local seadoo dealer (not les Cooke but I was thinking it was similar) and after getting it back it didn't feel any faster through the bottom end or mid range would only gain a few mph on the top end

    i am not monitoring the afr as yet,

    stock 48's are in there with the x charger

    its as if the soft limit is in place for the first 10mins of riding then it allows it to go to the hard limiter of 8180.

    I might have to throw the stock prop in and see if it spins over 8180 as the stock prop should get to 8300-8400

  6. #5
    I'm hitting 8550 with an 8650 tune and retainers on stock prop. I have a 2010 255 tho

  7. #6
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    For it to stop at 8180 it still has the stock limiter in there.
    If your going to be pushing higher rpms I suggest monitoring your afr...

  8. #7

    Join Date
    Feb 2014
    Location
    Sydney Australia
    Posts
    125
    +1
    12
    My stock rxpx 2013 revs to 8140. No way you have a tune

  9. #8

    Join Date
    May 2011
    Location
    Newcastle Australia
    Posts
    72
    +1
    1
    Thanks for the comments guy

    when it is was stock it would spin 8040ish at (70mph / 114kph)
    with the tune and prop it went 8180 at (75mph /121kph)

    is it fair to say with the mods of gen 3 cooler, hard cooler pipes, 4 intake, fa removed it should have gained at least some rpms?

    any idea why it can't go higher then 8040 for the first 10 mins or so? Does this happen on any other tune?

  10. #9

    Join Date
    Aug 2013
    Location
    Connecticut
    Posts
    99
    +1
    19
    Sounds like all the dealer did for a tune was get rid of your speed limiter and they left the rpm limiter in place, you should get more info on your tune from them, it would explain alot of whats going on

  11. #10

    Join Date
    Feb 2014
    Location
    Sydney Australia
    Posts
    125
    +1
    12
    I ran my ski today with boost box and it pulled really hard out of the hole and had slight cavitation at start then continued to pull hard in the mid range. Top end no change. I am happy as it was only a 250 bucks worth of mod. You have spent upwards of 3.5 to 4 k. If I was you I would be pissed listen to what these guys are saying My top speed is 69.

Page 1 of 5 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Can't get RPM's over 7600 no matter what we do on an 09 Ultra 260x
    By Jordan #94 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 11
    Last Post: 07-24-2011, 09:13 AM
  2. Can't my 2008 rxt to get over 60 khm
    By bob_gor in forum 4-Tec Performance
    Replies: 1
    Last Post: 01-24-2011, 07:12 AM
  3. Can't get boat over 3,000 RPM
    By jeh0319 in forum Sea Doo Sport Boats
    Replies: 0
    Last Post: 06-06-2010, 04:47 PM
  4. Why can't i get over 70?
    By Livin on the Edge in forum Kawasaki PWC Performance (4-stroke)
    Replies: 11
    Last Post: 09-08-2008, 11:14 AM
  5. stage1 rxp can't get over 68.2?????
    By rapidacceleration in forum 4-Tec Performance
    Replies: 19
    Last Post: 08-30-2008, 07:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •