Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 35
  1. #1

    Spark in PERMANENT limp mode

    Not sure if this is a doubble post or not but its good info and can be repeated.

    We ( chris australia) found out that some error codes puts the Sea Doo Spark in a permanent limp mode!
    Say that you get a low olil warning or just a glitch in some sensor.

    The Spark will then jump in to limp mode - max 3000 rpm ish(correct me if I am wrong on this number)

    On other skis you can just restart the ski and you got full power again.

    But on the Spark you need to go to a dealer and the the error code cleared!
    So you cant drive the ski until you find a dealer, and that can be a bit boring.

    But luckily you can reset any error code with the maptuner or the data logger from vtechtuned.com

    So another reason to get a maptuner for you Spark!
    (This applies to both stock and tuned skis!)


  2. #2
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Ouch for anybody that doesn't have a tuner to reset the codes...


  3. #3
    Tiny's Avatar
    Join Date
    Sep 2006
    Location
    The Atl
    Posts
    3,561
    +1
    578
    No offense, but giving the general public the ability to turn off/reset fault codes without getting them fixed can be a big old can of worms...

    Thats how some people claim to be mechanics......

  4. +1 by:


  5. #4
    GasResearch-VT.SE's Avatar
    Join Date
    Nov 2012
    Location
    Melbourne, Australia
    Posts
    1,172
    +1
    207
    Yes tiny, agreed... But if the code is in history and not an active fault - you should be all good.

    I guess most members on here are fairly educated on their skis with the amount of info everyone pumps out (like from members like yourself)


    The problem we have found is if the spark is left engine running (upside down) for more than approx 2 seconds before the lanyard is pulled, it will throw "low oil pressure".

    The ski when righted will run and the code will be in history but limp mode doesn't go away.

    So imagine you rode 15 miles to go jumping at your favorite spot, you fall off and forget to pull the lanyard when the ski is upside down... You rotate the ski jump on and it's time to go home... 15 miles all of a sudden is a long way when you can only go 6 mph!!!

  6. +1 by:


  7. #5
    Does this seem to be intentional or a bug that sea doo may patch in the future?

  8. #6
    SLASHER's Avatar
    Join Date
    Jun 2007
    Location
    Australia, Perth WA
    Posts
    3,263
    +1
    474
    I had mine latch into LOW OIL fault as I had it flip and run upside down for a few sec...

    I rode back to shore in limp mode and clear and reset with map tuner and back to normal ...

    it seems to be when latched it won't clear of limp mode until clear and reset ...

  9. #7
    SLASHER's Avatar
    Join Date
    Jun 2007
    Location
    Australia, Perth WA
    Posts
    3,263
    +1
    474
    I had another friend once he turned it off and right side up it cleared from limp mode , where mine didn't ...

  10. #8
    JayDog's Avatar
    Join Date
    Nov 2013
    Location
    Apollo Beach, FL
    Posts
    127
    +1
    16
    Just picked my spark up today. Yes I managed to flip it but it stayed running a few seconds but luckily no error code.

  11. #9
    SLASHER's Avatar
    Join Date
    Jun 2007
    Location
    Australia, Perth WA
    Posts
    3,263
    +1
    474
    I bet yah there is a Firmware update and some got it from factory and the earlier batch didnt...

  12. #10
    GasResearch-VT.SE's Avatar
    Join Date
    Nov 2012
    Location
    Melbourne, Australia
    Posts
    1,172
    +1
    207
    There will be an update from BRP on this. Its unacceptable for the aftermarket to fix such a fault. New software version for sure.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. MSX150 water in oil, limp mode
    By Dakota12 in forum MSX/Matrix
    Replies: 1
    Last Post: 05-01-2015, 10:43 AM
  2. MSX150 water in oil, limp mode
    By Dakota12 in forum Kawasaki Open Discussion
    Replies: 0
    Last Post: 05-01-2015, 12:45 AM
  3. virage tx in limp mode
    By tcar321 in forum Polaris Open Discussion
    Replies: 8
    Last Post: 06-06-2008, 03:03 PM
  4. Rxp In Limp Mode
    By BGslugger in forum 4-Tec Performance
    Replies: 0
    Last Post: 08-09-2007, 06:42 PM
  5. 2001 virage txi in limp mode
    By andrewplease in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-12-2007, 07:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •