Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23
  1. #1

    2004 GTX SC Limited wont hit max rpms

    Hello everyone, I am hoping you guys can help shed some light on why my seadoo gtx sc wont turn past 7350 rpms. I have a 4" intake, 2 degree wedge, riva intake grate, opas block off's and a rebuilt SC by Jerry. Prop and WR are with in spec. All maintenance done and I recently replaced the Head with a refurbished one from SBT. Runs like a champ, does not show any abnormalities but wont go past 61 and 7350 tops. It averages 7200 at 58. Its got 96 hours on it. Any insight would be greatly appreciated.


  2. #2
    brendanm's Avatar
    Join Date
    Jan 2013
    Location
    Gold Coast, Australia
    Posts
    738
    +1
    149
    What prop is in it? Might be too steep. Mine has been playing up with low rpm and bogging lately, turns out to be an exhaust leak at the v band flange. Perhaps check for exhaust leak, if you've had the head done it would all have been apart.

  3. #3
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    What are your compression #s?

    Is the oil at the correct level and not over full?

    Did this start when you replaced the head?
    I would start by putting a new set of plugs in it and running a double dose of fuel injector cleaner thru it.

    04 with 96 hrs is only 9.6 hrs a year so its had to have old fuel in it....

  4. #4
    dont know the numbers, im fairly certain they are fine, but il verify. As for the oil, I may have overfilled it a touch since I didnt know I had to idle it for 30 seconds to properly check it. I believe this started after the head job. There is also steam or white smoke for a second after a long wot run. I dont believe the head is leaking but il also do a block test to verify. The vband could be a culprit since the exhaust rotted away and I had it re-welded. How can i check the what prop I have?

  5. #5
    brendanm's Avatar
    Join Date
    Jan 2013
    Location
    Gold Coast, Australia
    Posts
    738
    +1
    149
    Steam out the back is normal, if it dissipates quickly it is a team and nothing to worry about. To check the prop you will have to remove it and find what numbers are on it.

    When you say exhaust rotted away, do you mean the bell on the exhaust manifold? This is generally a sign of running lean.

  6. #6
    The bell mouth, it was re-welded and seem to be snug, but It might be leaking, There is a tiny bit of salt around there after every ride, could be fumes in my engine bay. I also have a borascope so maybe I wont have to remove the prop? where would the numbers be? Thanks alot guys you really help me rest easy. What are the chances I botched the timing? I locked the crank and cam and zip tied the wheel.

  7. #7
    brendanm's Avatar
    Join Date
    Jan 2013
    Location
    Gold Coast, Australia
    Posts
    738
    +1
    149
    A bit of salt stuck around the v band is what mine was doing as well. If you look at the v band clamp, you shouldn't see the V stick out past the clamp, if that makes any sense?

    If a Solas the prop numbers should be stamped into the body of the prop near where it screws into the pump.

  8. #8
    Thanks for the Tip, but if this is the case how are you turning 66 at 7200 and I turn 58 at 7200? still doesn't add up? I must be lean making less power at the lower Rpm...

  9. #9
    brendanm's Avatar
    Join Date
    Jan 2013
    Location
    Gold Coast, Australia
    Posts
    738
    +1
    149
    Bigger charger. Also have a 13/21 prop. That's why you need to check the prop.

  10. #10
    Thanks again guys! I think It was an exhaust leak. I tightened it up and ran it today, it was too choppy to get it up to speed but It feels like it pulls alot harder!

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 GTX SC 185hp 5800rpm Max
    By steelroe in forum 4-Tec Performance
    Replies: 10
    Last Post: 08-23-2013, 07:37 AM
  2. To Buy 2003 & 2004 GTX SC Limited
    By Fechner in forum 4-Tec Performance
    Replies: 8
    Last Post: 06-13-2013, 03:41 PM
  3. wtb impeller for 2004 gtx sc limited
    By OHIOJOE in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 07-28-2009, 07:19 AM
  4. RXP ECU vs ROTAX RACING ECU for 2004 GTX SC LIMITED
    By Totallyblown in forum 4-Tec Performance
    Replies: 4
    Last Post: 11-19-2005, 05:54 PM
  5. 2004 GTX SC with plastic pump?
    By Green Hulk in forum 4-Tec Performance
    Replies: 17
    Last Post: 08-15-2005, 09:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •