Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    Join Date
    Mar 2013
    Posts
    230

    Vibrations on a 1995 SLT 750

    I bought this jet ski last year. It runs and idles good, but I noticed late last season, when I was in the no wake zones or pulling something, it had vibrations. It went away if I went faster.

    What would cause it??? Thanks
    Last edited by K447; 02-26-2014 at 01:37 PM. Reason: Not a 1996 stx 1100


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,597
    +1
    1,276
    What brand is this machine?

    Model Year is the last two digits of the HIN number plate on the rear deck.

  3. #3

    Join Date
    Mar 2013
    Posts
    230
    It is a 1995 polaris slt 750 jet ski with the vibrations

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,597
    +1
    1,276
    Quote Originally Posted by jasonmd13 View Post
    It is a 1995 polaris slt 750 jet ski with the vibrations
    Vibrations can be caused by multiple possible things.

    I would start by inspecting the driveline and the engine mounts. Also check the engine cylinder compression.

    Visually inspect the engine mounts for signs of failure or looseness. Then grab the top of the engine or large exhaust pipe and really shove it hard side to side. The engine should flex only a little as the rubber engine mounts flex, just a little.

    Remove the jet pump and inspect the drive shaft, the jet pump impeller bearings and the drive splines (drive shaft, impeller, engine coupler).

  5. #5

    Join Date
    Mar 2013
    Posts
    230
    Is the jet pump and impeller hard to remove? I did get a little slippage feeling from time to time

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,597
    +1
    1,276
    Quote Originally Posted by jasonmd13 View Post
    Is the jet pump and impeller hard to remove? I did get a little slippage feeling from time to time
    Click on my signature links. There is a Jet Pump section with lots of info and even video links.

  7. #7
    RLACEMAN's Avatar
    Join Date
    Aug 2011
    Location
    Random Lake WI
    Posts
    884
    +1
    54
    If this 'vibration' is present only when idling & goes away once you get the rpms above 2000 or so, this is normal for this ski. Anything more than that is not normal.

  8. #8

    Join Date
    Mar 2013
    Posts
    230
    I tried to pull another broken jet ski and the vibration was really bad and I had to stop pulling it

  9. #9

    Join Date
    Mar 2013
    Posts
    230
    Any idea what it could be, that would be worse if I pulled something?

  10. #10
    scorp's Avatar
    Join Date
    Nov 2006
    Location
    Eastern,PA.
    Posts
    227
    I would do what K477 has advised you to do in post #4, there are 3 "ideas" that tell you "what it could be". You definitely need to check and go through your ski before it gets worse, $$$. I had a similar problem and found 1 of my rear motor mounts had detached from the hull, but not before stripping the splines on my driveshaft & coupler leaving me dead in the water.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Questions on the 1995 SLT 750 engine
    By VDRIVE79 in forum Polaris How To & FAQs
    Replies: 31
    Last Post: 08-24-2015, 02:36 PM
  2. base timing on 1995 slt 750
    By zakatak in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-10-2009, 09:37 PM
  3. FS 1995 SLT 750 Polaris
    By jarcynvicnchris93 in forum Polaris Classifieds
    Replies: 1
    Last Post: 06-05-2008, 08:02 PM
  4. Question on a 95 slt 750
    By fred85 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 07-30-2007, 12:33 PM
  5. Just purchased a 1995 SLT 750.. Questions
    By daveo13 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 09-08-2006, 03:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •