Results 1 to 4 of 4
  1. #1

    Join Date
    Mar 2014
    Location
    New Hampshire
    Posts
    1

    2001 polaris Virage magneto

    My 2001 Virage kills every bettery I out into it.. it runs great for about 2 hours then just dies and will not start.. I took the new batteries to a mechanic who tested them and was told thay are no good.. The ski seems to be depolerizing the batteries. I have taken the magnety/stator out and am about to purchase a new one... Is this the cause of my battery issue? the batteries do not go dead when the ski is at the dock it only runs them dead when running.. any help would be greatly appreciated


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Welcome

    Have you checked the charging system?

    When the engine is running the battery voltage should be around 14.5 DC volts or so, and remain stable as RPM changes. Anything under 13.5 volts with engine running indicates the charging system is not actually working.

  3. #3

    Join Date
    Mar 2014
    Location
    Indianapolis Indiana
    Posts
    31
    Sounds like you are on the right track! But it would have me stumped as well.... may try searching if a pos and neg are crossed somewhere allowing for the battery to drain when the power is being allowed from the Hall effect sensor(the sensor that lets power to the orange wire when the crank is turning) maybe there is a strip somewhere along the orange wire that is grounding and draining the electrical. Check out K447 's avatar and look into his pages about where electrical is explained.

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Quote Originally Posted by wheeman2222 View Post
    Sounds like you are on the right track! But it would have me stumped as well.... may try searching if a pos and neg are crossed somewhere allowing for the battery to drain when the power is being allowed from the Hall effect sensor (the sensor that lets power to the orange wire when the crank is turning) ...

    Check out K447 's avatar and look into his pages about where electrical is explained.
    This is not how the Hall Effect sensor works. You are confusing the ignition system with the LR module functions.

    Reversed battery polarity would cause all sorts of troubles, of course. LR module damage would be likely, even stator damage is possible. Starter would spin backwards so bendix would not engage.

    Make very sure battery negative post is connected to engine ground.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 polaris virage conversion
    By jeeprunnr in forum Polaris Projects
    Replies: 6
    Last Post: 03-27-2007, 08:19 PM
  2. 2001 Polaris VIRAGE TXI performance upgrades?
    By john8873 in forum Polaris PWC Performance
    Replies: 7
    Last Post: 03-08-2007, 06:36 PM
  3. Need 2001 polaris virage electrical Resistances
    By jeeprunnr in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 12-21-2006, 11:14 AM
  4. 2001 polaris virage
    By jeeprunnr in forum Polaris Open Discussion
    Replies: 14
    Last Post: 11-24-2006, 01:16 AM
  5. Needed: service manual 2001 polaris Virage
    By jeeprunnr in forum Polaris How To & FAQs
    Replies: 7
    Last Post: 11-13-2006, 11:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •