Results 1 to 6 of 6
  1. #1
    clements77's Avatar
    Join Date
    May 2013
    Location
    Arma, KS
    Posts
    41

    RXP Driveline Leak Help Please!!!

    Hey guys. I fought a driveline leak all last season. It started after I replaced the impeller and wear ring. I figured the factory seal was bad so I replaced the carbon ring, bellows and o-rings in the top hat and still had a leak. It was intermittent. It would do it once I put it in the water but once I took off it would seal up. After I shut it off and let it sit for a while it would start leaking again. I tried sliding the bellows up toward the motor to increase the pressure and that seemed to stop it until I left it in the water over night (beached luckily) and found the engine compartment pretty full the next morning. I'm giving in and taking it somewhere to get fixed so I'm not fighting it all year again. I'm in southeast Kansas. Does anybody know of a good shop that's somewhat close? The nearest is down on Grand Lake about an hour and a half away and they nailed me last time on a hull repair. Any input would be appreciated. Thanks!


  2. #2
    SuperCharged67's Avatar
    Join Date
    Jun 2012
    Location
    Halifax, NS, Canada
    Posts
    1,962
    +1
    76
    Could it be leaking from the plugs in the rear? Sometimes the seals in them go bad.

  3. #3
    Drive shaft bumper is worn allowing the drive shaft to move in and out.

    When you changed the drive did you apply grease to the drive shaft?

    Its possible that it may have hydraulic locked in the impeller pushing the drive shaft away from the bellows and into the engine.

  4. #4
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    While your fixing it I would have a bilge installed.
    Better safe then sorry!!!


  5. #5
    SuperCharged67's Avatar
    Join Date
    Jun 2012
    Location
    Halifax, NS, Canada
    Posts
    1,962
    +1
    76
    Also get some insurance for if it sinks!

  6. +1 by:


  7. #6
    clements77's Avatar
    Join Date
    May 2013
    Location
    Arma, KS
    Posts
    41
    The plugs are good. I can see it spraying around the ring. I forgot all about that bumper on the end of the shaft. I'll get one coming and see if that changes it. I plan on a bilge too once it finally warms up here. Luckily I have full coverage on it already which proved helpful the first time out when I punched a hole in the hull being stupid.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 RXP Knock adapter help please
    By flnsx in forum 4-Tec Performance
    Replies: 11
    Last Post: 07-20-2013, 08:21 PM
  2. Replies: 1
    Last Post: 06-05-2010, 09:17 PM
  3. 97 SL900 Leak Help Please
    By christian79 in forum Polaris Open Discussion
    Replies: 0
    Last Post: 08-15-2007, 09:29 AM
  4. RXP engine damge help please
    By Saleh RXP in forum 4-Tec Performance
    Replies: 4
    Last Post: 06-03-2007, 05:09 PM
  5. RXP Handling !! Anyone help please
    By rxp_boy in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-17-2005, 02:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •