Results 1 to 3 of 3
  1. #1

    Join Date
    Mar 2014
    Okinawa, Japan

    Post 2002 4-tec CHK eng issue

    So I have a bit of an issue.... Whenever I take my ski out it works like a charm for about the first 10-15 minutes. After that, the CHK ENG light comes on and I get the tone. I didn't even think to hit Set 5 times when it happened. It eventually went away then came back. I can't get it to happen on the hose most likely do to the fact that I'm not running it as long on the hose (not that I wanna run it for a long time). But it doesn't enter limp mode or anything. It runs normally. Anyone have any ideas?

  2. #2
    wotxxxsd's Avatar
    Join Date
    May 2012
    Welcome aboard the Hulk!!!

    I've seen this issue before and it turned out to be a sensor starting to take a dump... on the ski I had it turned out to be the exhaust temp sensor. Older doos are also known to have bad oil pressure sensors also.
    So until it kicks and logs into your ski all you can dooo is ride it until the code logs itself or start switching sensors out which can get expensive quick...
    As long as your oil and coolant are full then rip on...just keep an eye out for issues.

    Just my .02

  3. #3

    Join Date
    Mar 2014
    Okinawa, Japan
    Thank you! Yeah I was leaning in the direction of a sensor. I just didn't know which ones could cause this issue. I'm glad you've seen it before. I think I'll get into the troubleshooting guides and follow the fault codes for any faulty sensor. Shoot the wires and see if something is out of the norm. Thank you for your input, I really appreciate it! I'll let you know what I find!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Steering/Handling Issues 2002 4-TEC GTX
    By 20024tecgtx in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-02-2013, 07:03 PM
  2. 2005 rxp chk eng p0326
    By LOFLYN in forum 4-Tec Performance
    Replies: 3
    Last Post: 04-04-2010, 06:52 PM
  3. Chk eng #p0344??
    By Kaybat in forum 4-Tec Performance
    Replies: 23
    Last Post: 10-04-2009, 11:42 AM
  4. 2002 4 tec $500.00 Miami Fl
    By james21 in forum Sea Doo Classifieds
    Replies: 4
    Last Post: 05-22-2008, 04:42 PM
  5. 1100stx bogging&chk.eng
    By frankraineri in forum Kawasaki Open Discussion
    Replies: 0
    Last Post: 08-13-2007, 06:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts