Results 1 to 8 of 8
  1. #1

    Post knoken sensor p0326

    seadoo rxt 07 knoken sensor problem , when i go 7500 rpm alarm and check eng and code p0326 start flashing. what could be wrong on the eng.could i still ride the jet ski.my rpm use to be 8150 and now 7900 max. Gas 91 use all the time. I CHECK knoken sensor and harness is good .I was doing 71 mph and now 63mph please help me.
    Last edited by pollogallo; 03-18-2014 at 08:38 PM. Reason: missing information


  2. #2

    Join Date
    Mar 2006
    Posts
    1,829
    +1
    119
    I have seen a knock sensor go bad. Easy to try a known good part on your machine. How did you "check" your knock sensor?

  3. #3
    Pwgsx's Avatar
    Join Date
    Sep 2006
    Location
    DFW- TX
    Posts
    1,196
    +1
    38
    Replace the sensor and get the error code deleted.

  4. #4
    oct6454's Avatar
    Join Date
    Sep 2008
    Location
    Gig Habor, Washington
    Posts
    758
    +1
    8
    Agree with the post above, go ahead and replace the sensor. Make sure to clean the surface where the knock sensor mounts to the block as well as torquing it to correct specs.

    The knock sensor is located underneath the intake manifold so pull that off and you see the knock sensor bolted to the block.

  5. #5
    I replaced the knock sensor, and i still have the same problem. And i also checked the harness cable and it was working fine. What else could it be?

  6. #6
    oct6454's Avatar
    Join Date
    Sep 2008
    Location
    Gig Habor, Washington
    Posts
    758
    +1
    8
    It can be bad gas...try and run it low on gas then go fill at a different station and see if that changes anything. Have you tried clearing the code?

  7. #7
    Primary Language: Sarcasm Pony Racer's Avatar
    Join Date
    Jun 2011
    Location
    RiverShit, Ct
    Posts
    480
    +1
    28
    check for corrosion on all the wires leading to the knock sensor..

    if the shielding gets corroded it can disintegrate over time giving a false knock code to show up..

    just read about this on the riva forums earlier today..
    http://rivaforums.com/eve/forums/a/t...4/m/6450034866

    not saying this is the issue.. but worth a check

  8. +1 by:


  9. #8
    Thank you everybody for helping me with my problem. I found out that the problem was on the harness resistant number 1 to number 9 it wasn't resistant, and number 2 to number 23 was resistant. So I went to and replaced the whole engine harness, and I fixed the problem. I hope this helped somebody with the same issue.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2005 RXT P0326 knock sensor out of range diagnosis
    By TJBrad04 in forum 4-Tec Performance
    Replies: 3
    Last Post: 10-01-2016, 12:17 AM
  2. P0326..knock sensor
    By shore in forum 4-Tec Performance
    Replies: 9
    Last Post: 04-26-2016, 08:44 AM
  3. P0326 after rebuild. knock sensor?
    By spannerspencer in forum 4-Tec Performance
    Replies: 15
    Last Post: 10-16-2014, 08:37 PM
  4. 06 RXP Knock Sensor Problem P0326
    By Antiguan FZR in forum 4-Tec Performance
    Replies: 3
    Last Post: 12-05-2012, 12:40 PM
  5. rotax ecu and knock off sensor warning P0326
    By otoss in forum 4-Tec Performance
    Replies: 5
    Last Post: 02-13-2011, 04:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •