Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 30

Thread: RXT 260 problem

  1. #1

    RXT 260 problem

    When I used ski last year for the last time my niece went to drive it and it acts like something is in the impeller blocking water intake engine revs but goes nowhere. Had problem once before and reverse gate was stuck halfway down but turned of restarted and it was fine but didn't work this time. Curious if anyone else has had this issue before I get raped by the dealer again


  2. #2
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,037
    +1
    672
    That's not much detail. What year? Is it making any noise? Have to checked to make sure the gate is up? Is it loaded with sea grass?

  3. #3
    My friend has an 08 RXT that did exactly the same. Turns out his was a very bad prop n WR. Maybe you sucked up something n destroyed the WR or prop or both.

    On his it also vibrated like crazy, shaking n rattling the bodywork.

    Poke your head under and take a look in the grate, it'll give you a clue maybe.

  4. #4
    SuperCharged67's Avatar
    Join Date
    Jun 2012
    Location
    Halifax, NS, Canada
    Posts
    1,962
    +1
    76
    Stripped Splines?

  5. #5
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    There are quite a few things to look at.
    1. Something could be stuck in the intake grate and or impeller.
    2. Wear ring could be wore from sucking something up. eg rocks, sand
    3. Carbon ring could going out. Check to see if the ski takes on water while trying
    to accelerate.
    4. Prop could be damaged.

  6. #6
    dsteinmann's Avatar
    Join Date
    Apr 2012
    Location
    St Louis
    Posts
    278
    +1
    8
    Is that a 2010 In his pic? Didn't the 10's have bad driveshaft's

  7. +1 by:


  8. #7

    Join Date
    Aug 2013
    Location
    Connecticut
    Posts
    99
    +1
    19
    They did have bad driveshafts in 2010 on the rxt 260, i bet the splines on the shaft and gone!

  9. #8
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    3,849
    +1
    742
    I know one thing I would remove the iBr, pump and closely inspect the impeller, wear ring, drive shaft splines all myself before I took it anywhere!

  10. #9
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Where are you located. Someone on here might be able to refer you to someone who will not rape you on fixing it.
    Also call in your vin # to a seadoo dealer to see if there are any free updates.

  11. #10
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Quote Originally Posted by dsteinmann View Post
    Is that a 2010 In his pic? Didn't the 10's have bad driveshaft's
    Oooooooh. Forgot about that.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2012 rxt 260 fuel pressure problems
    By meinstein1987 in forum 4-Tec Performance
    Replies: 11
    Last Post: 07-16-2016, 09:42 AM
  2. Major Seadoo RXT X 260 problems
    By Dan16 in forum Sea Doo Open Discussion
    Replies: 19
    Last Post: 01-10-2015, 01:27 AM
  3. 2010 sea doo rxt 260 problems
    By jordanmow in forum 4-Tec Performance
    Replies: 47
    Last Post: 09-14-2014, 05:44 PM
  4. RXT 260 problems after Fizzle intake & catch can
    By JPizzle in forum 4-Tec Performance
    Replies: 12
    Last Post: 12-06-2013, 07:20 PM
  5. RXT-X problem?
    By marcelaw97 in forum 4-Tec Performance
    Replies: 7
    Last Post: 05-29-2008, 11:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •