Results 1 to 9 of 9
  1. #1

    Weird Virage Txi Noise

    I bought a virage Txi last year for a great deal. 800 bucks!! It had the problem in the fuel tank of that pesky pressure regulator falling into the tank. I took it apart put it back on just to have it fall off again. I proceeded to cut the line and add the kawasaki in line regulator. Fantastic idea for that I thank the forum. Anyway now to my question. At idle, and much more audible out of the water. I get a pretty good vibration, and when out of water get a loud ringing noise almost like something metal is scuffing something else. Any ideas what this might be? Can I still find parts for this ski?


  2. #2
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    The ringing type noise you hear is the jet pump, and is quite normal for a Polaris. It would be very worth your time to remove the jet pump, and inspect the condition of the bearings and seals. Pull the pump tail cone and check for water intrusion. The jet pumps can be rebuilt with new bearings and seals for less than 50 bucks. Also a good time to inspect the impeller for wear and have it refurbushed if necessary. As long as everything is apart, replace the seals on the driveshaft as well. Its cheap insurance. You should be able to do all of that for less than 75 bucks not including the impeller if necessary

  3. #3
    Miglater's Avatar
    Join Date
    Apr 2013
    Location
    Howell, MI
    Posts
    424
    +1
    25
    Congrats on the virage, they are nice skis.

    Don't forget to lube the driveshaft splines while your have it apart. Should have a rubber bumper on each end of the driveshaft too which can fall out during dis-assembly. Also, check and replace the thru hull bushings and seals if necessary.

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,569
    +1
    1,272
    Quote Originally Posted by Miglater View Post
    ... check and replace the thru hull bushings and seals if necessary.
    Quote Originally Posted by BryanP View Post
    ... As long as everything is apart, replace the seals on the driveshaft as well...
    See my signature links for part numbers and notes regarding the seals and bushings in the through-hull bearing assembly.

    Inspect the driveshaft surface where it passes through the bearing. Surface roughness, excessive grooving or corrosion are not desirable.

    See the Jet Pump sections from my signature notes regarding jet pump removal, inspection, bearing replacement, etc.

    Check the drive splines at each end of driveshaft for wear. Always grease the splines during reassembly.

    Quote Originally Posted by calarco3 View Post
    ... At idle, and much more audible out of the water. I get a pretty good vibration, and when out of water get a loud ringing noise almost like something metal is scuffing something else...

    Can I still find parts for this ski?
    Welcome

    It is typical for Polaris impellers to 'ring' while running out of the water. The sound apparently comes from rotational looseness in the driveline splines 'shaking' the impeller as it rotates and pulses with each engine power stroke.

  5. #5
    Sorry for the late reply but I took the pump apart replaced bearings and several seals put it all back together. Impeller seemed fine to me and i found i have the upgraded stainless stator in there. Score! However, still same noise. Should I just not worry about it and enjoy this great ski?

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,569
    +1
    1,272
    Quote Originally Posted by calarco3 View Post
    Sorry for the late reply but I took the pump apart replaced bearings and several seals put it all back together. Impeller seemed fine to me and i found i have the upgraded stainless stator in there. Score! However, still same noise. Should I just not worry about it and enjoy this great ski?
    Did you put waterproof grease into the splines before installing the drive shaft and jet pump?

    Rubber bumpers in place on both ends of the drive shaft?

    SS jet pump stator was factory OEM on the Virage TX models.

  7. #7
    Yes blue waterproof grease and actually forgot one and had to take apart and put on.

  8. #8
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,569
    +1
    1,272
    Quote Originally Posted by calarco3 View Post
    Yes blue waterproof grease ...
    So you have a metallic ringing sound when the engine is idling out of the water. In the water the sound is much quieter or completely gone, correct?

    If so, that is normal Polaris jet pump operation

  9. #9

    Thanks

    Thanks, for all your help K much appreciated, thanks to all others as well. Now to tackle the issues with the new 2002 virage txi twin that I just fell into this week. Ran fine then really rough... another issue.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 19
    Last Post: 11-19-2014, 10:03 AM
  2. 2002 Polaris Virage TXi.. HELP!!! WON'T START
    By fitch615 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 06-05-2007, 04:31 PM
  3. 2001 Polaris VIRAGE TXI performance upgrades?
    By john8873 in forum Polaris PWC Performance
    Replies: 7
    Last Post: 03-08-2007, 06:36 PM
  4. Virage txi Giving me trouble
    By Mauivirager in forum Polaris How To & FAQs
    Replies: 21
    Last Post: 12-19-2006, 06:21 PM
  5. virage txi help
    By superduty in forum Polaris PWC Performance
    Replies: 4
    Last Post: 09-11-2006, 04:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •