Results 1 to 7 of 7
  1. #1

    Polaris 95 SL750

    My SL750 starts and runs fine if you prime the carbs but it wont start on its own. Fuel lines/filters seem to be fine since it runs fine once it starts. Thanks.


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,593
    +1
    1,275
    Welcome

    How long have you owned this machine?

    What service and maintenance has been done recently?

    When were the carburetors last taken apart, internally cleaned and rebuilt?

    Does it still have the original Tempo brand gray fuel hoses?

  3. #3
    john zigler's Avatar
    Join Date
    Aug 2006
    Location
    WI
    Posts
    2,545
    +1
    33
    Unless you know the history of this machine, ( Like K447 has asked above, ) I would recommend a COMPLETE fuel system upgrade.....

    New lines, fuel select, rebuild the carbs, triple fuel pump up grade, etc.

    Be sure to check the tank vent, and gas cap / filler neck for cracks.

    Failure to do all of the above WILL result in engine failure.

  4. #4
    Thanks for the reply. I have had it 5 years, it came with the lake house, and not had to do anything to it other than replace the driveshaft. It has some other things that don't work like the trim, the LCD, and it porpoises so bad you cannot ride it without getting soaked if there are any waves on the lake. I am not going to spend money or time on this dinosaur and just get something new. I was hoping for something simple. I appreciate the feedback.

  5. #5
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    It porpoises because the trim isnt working. Its a really fun ski when its working right

  6. +1 by:


  7. #6
    LaveyT's Avatar
    Join Date
    Jul 2008
    Location
    Cincinnati
    Posts
    672
    +1
    10
    Click image for larger version. 

Name:	Bryan on Dino.png 
Views:	26 
Size:	81.7 KB 
ID:	325436 Saddle up that Dino!

  8. #7
    LaveyT's Avatar
    Join Date
    Jul 2008
    Location
    Cincinnati
    Posts
    672
    +1
    10
    Your trim is probably stuck in the Full Up position. I rigged my old SL 750 back to level but it has a tendency to work its way back to "up Trim".
    These ski's are simple to work on, but if you don't enjoy it its not fun.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Polaris 94 Sl750 and 95 Sl750
    By jwubbena in forum Polaris Open Discussion
    Replies: 1
    Last Post: 07-18-2008, 12:21 PM
  2. Towing '95 SL750 ?
    By dorf in forum Polaris How To & FAQs
    Replies: 19
    Last Post: 07-20-2007, 11:49 PM
  3. '95 SL750: Can a stator be tested when uninstalled?
    By SeaBee63 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 06-11-2007, 11:23 PM
  4. Does a 95 Sl750 have the same number of veins as a 96 slx 780?
    By gvnitup in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 05-28-2007, 12:05 PM
  5. 95 sl750 questions
    By 95 sl750 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 04-16-2007, 05:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •