Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    04 gpr 1300 will not idle down

    Pulled off the expansion chamber to check for oil leaks. Put the pipe back on and the ski revs up to 6krpm and stays there, will not idle down. Checked all my electrical connections, water connections to the pipe and throttle cable for binding to no avail. What am I missing? Ski ran perfect before I pulled the expansion chamber. Any help would be greatly appreciated


  2. #2
    powerstroke specialist mikegp's Avatar
    Join Date
    Mar 2011
    Posts
    2,529
    +1
    190
    when you install the pipe back,did you ran the throttle cable the right way?

  3. #3
    That was my 1st mistake. Had it ran under the pipe. I corrected it to no avail. After doing another once over, I noticed one of the YPVS cables was not connected on the shaft. Wonder if it was opening causing it to idle up? After work today I will re-connect it and post the results. I appreciate your help !

  4. #4
    Derek45's Avatar
    Join Date
    Feb 2014
    Location
    MO. Mark Twain, LOTO
    Posts
    461
    +1
    26
    when you reconected the throttle cable, if you tightened it and pulled some tention on it that may be your issue, may have to loosen the cable to give the cable some slack, to check this, loosen to give slack and keep loose try to start, it should not without giving gas, then back it off some tighten and try again, may have to adjust the cable a few more times to get it set right.

  5. #5

    Join Date
    Feb 2010
    Location
    Tampa, Florida
    Posts
    103
    +1
    6
    Does the jetski have carbs or no? if it does have carbs, one of the butterfly shafts may be sticking a bit. Once I pulled the shaft out and lightly sanded the inner part of the rubber seals, shaft turned smoothly. michael

  6. #6
    powerstroke specialist mikegp's Avatar
    Join Date
    Mar 2011
    Posts
    2,529
    +1
    190
    Quote Originally Posted by lawyerboy View Post
    does the jetski have carbs or no? If it does have carbs, one of the butterfly shafts may be sticking a bit. Once i pulled the shaft out and lightly sanded the inner part of the rubber seals, shaft turned smoothly. Michael
    its a 1300 .

  7. #7
    I reconnected the ypvs cable the ski idled down ok. I noticed while on the hose, the ski ides ok until you rev it or blip the throttle. Sometimes it will idle up to 6k and stay there until you pull the lanyard. other times it will idle down. Planning to put it in the water to see if it will do the same thing.

  8. #8
    Quote Originally Posted by lawyerboy View Post
    Does the jetski have carbs or no? if it does have carbs, one of the butterfly shafts may be sticking a bit. Once I pulled the shaft out and lightly sanded the inner part of the rubber seals, shaft turned smoothly. michael
    This one is a fuel injected 04. Thanks for the input though

  9. #9
    Took it out on the water yesterday for about 2 hours and it ran great. Then it started bogging so I turned it off and got towed in. Appears my gas gauge is reading incorrectly. Still runs like crap on the hose but great in the water.

  10. #10
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    Still runs like crap on the hose but great in the water.
    Perfectly normal. When unloaded the motor is pretty rich

  11. +1 by:


Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 657x will not slow down to idle
    By gfmgp in forum 2-Stroke Performance
    Replies: 7
    Last Post: 06-26-2010, 09:00 PM
  2. 2007 Yamaha GPR 1300 won't idle
    By Markg in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 05-26-2009, 04:32 PM
  3. 04 gpr new problem, not running right
    By wakewhornc in forum Yamaha PWC Performance (2-stroke)
    Replies: 36
    Last Post: 08-12-2008, 03:40 PM
  4. 04 gpr new problem, not running right
    By wakewhornc in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 08-09-2008, 01:09 PM
  5. '01 Virage TX will not idle
    By PWCGEEK in forum Polaris How To & FAQs
    Replies: 15
    Last Post: 12-04-2006, 09:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •