Results 1 to 7 of 7
  1. #1
    If i knew,...I wouldn't ask sea-one's Avatar
    Join Date
    Aug 2009
    Location
    Dallas/Waxahachie
    Posts
    2,340
    +1
    109

    Question on the 08 waterbox hose routing mod please

    Heres an old thread http://www.greenhulk.net/forums/show...box+hose+route

    but i have an 04 with these hoses on the bottom and Snowman's are different

    Click image for larger version. 

Name:	08 Waterbox 001.jpg 
Views:	68 
Size:	96.6 KB 
ID:	325736

    This hose bleeds out the back in the pump area
    Click image for larger version. 

Name:	08 Waterbox 002.jpg 
Views:	74 
Size:	81.1 KB 
ID:	325737

    Ski is apart so i'm waiting to see what to do from all of you, Thanks
    Last edited by sea-one; 04-06-2014 at 06:02 PM.


  2. #2
    Steve-m31164's Avatar
    Join Date
    Jan 2013
    Location
    Melbourne Australia
    Posts
    2,690
    +1
    403
    Have a look at www.seadoomanuels.net go to 2008+ rxp or t and look at the diagrams it will show you the routing ....

  3. #3
    Steve-m31164's Avatar
    Join Date
    Jan 2013
    Location
    Melbourne Australia
    Posts
    2,690
    +1
    403
    Or look through the greenhulk store OEM parts

  4. #4
    If i knew,...I wouldn't ask sea-one's Avatar
    Join Date
    Aug 2009
    Location
    Dallas/Waxahachie
    Posts
    2,340
    +1
    109
    Hers's what i did, please let me know if this works....
    1. The OEM "T" hoses on the bottom of the manifold,i moved to the top barb with the new Mid-pipe and Original barb fitting and connected there. This Feeds the Manifold / midpipe connection and the exhaust end exit port

    2. I put another "T" fitting back on the bottom of the manifold barb that goes to the outlet in the pump area AND the the "T" part i fed it to the Nipple barb on the waterbox.

    NOW... WILL THIS BE OK TO RUN? especially the waterbox feed?

    OH and i just discovered that the exhaust clamp WONT FIT!
    DAMN,...PART # 274001347

    AND it's fourty friggin dollars! man i'm so aggrevated at every nickle and dime!
    i don't even WANT to buy it! ...at least for now. god

  5. #5
    If i knew,...I wouldn't ask sea-one's Avatar
    Join Date
    Aug 2009
    Location
    Dallas/Waxahachie
    Posts
    2,340
    +1
    109

    Question on the 08 waterbox hose routing mod please

    Bump for confirmation on this water line set up PLEASE, i'm a little worried the "T" i added might flow too much and not cool enough and the hose to the water box is not regulated and i hope it won't dump too much water at idle or just off idle?.. please gimme some input on this..

  6. #6
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    When adding a mid pipe exhaust to an 07 and earlier ski..... that lower fitting on the exhaust manifold should go directly to the flush port on the pump shoe. If you have an external IC.... it's outlet line can also T into this location in some cases.

  7. #7
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    My setup is matched to the 08 RXP,NOT the X boat but the 215 hp RXP..It is pretty simple as most of the hoses as you can see are on top(and used from my 06 setup)...The 04 and 06 setups are identical so if you route it like mine youll have NO issues...On the top,as you can see,i tool the L-hose and ran it into the "T" fitting,from the "T" fitting i ran the pisser line to the pisser on top of the water box...Then coming out of the "T" fitting i ran that hose to mid pipe.....On the bottom i removed the T fitting and smaller hose and just connected the flush hose to that fitting...this way i can still flush or ru the ski on the hose if i want too.....Hopefully this helps you out..
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	100_3875.jpg 
Views:	63 
Size:	116.6 KB 
ID:	326159  

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. question on the 08 rebuild kit with metal washers.
    By Promod1955 in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-08-2009, 11:54 PM
  2. Quick Question on the Ultra
    By TheDome in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 06-30-2007, 04:54 AM
  3. question on the 135hp 1200 motor.
    By Water4fire in forum Yamaha Open Discussion
    Replies: 19
    Last Post: 03-04-2007, 10:17 PM
  4. quick question on the fuel tank (reserve?)
    By SHIFT in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 12-21-2006, 01:51 PM
  5. question on the ecu on a 1503 4-tec
    By chazavw in forum 4-Tec Performance
    Replies: 18
    Last Post: 12-23-2005, 05:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •