Results 1 to 7 of 7
  1. #1
    devils ride 250's Avatar
    Join Date
    Mar 2010
    Location
    lehigh valley pa
    Posts
    775
    +1
    124

    Problem with 250 pump

    Hey guys. Bad news. Was having my ultra with 220 hours on original bearings upgraded to the 300 pump set up. I have a solas 16/21 prop on it. While pulling the prop and shaft out the prop wouldn't come off. Here the prop itself seems like it twisted the threads and is locked on. Now I need new prop and shaft with all bearings and seals which I was changing anyway. Also the pump housing seems warped so I pretty much need everything down there. Has anyone seen this with the solas props "back threading" for lack of a better term? I do all ocean riding and bay and saltwater so it gets rough and fast. I never heard of a prop doing this. Is solas have to loose of tolerances that this could happen? Not sure what I am doing prop wise now. Any suggestions? Stock , 15/23. Someone on here has a 15/23 for sale. Very bummed out. Was hopeing to ride this weekend


  2. #2
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Brisvegas
    Posts
    4,158
    +1
    600
    Use heat on the centre area of the prop to release it...... thry can be FRIGGIN tight

  3. #3
    "just sayin".. jetdave56's Avatar
    Join Date
    Nov 2008
    Location
    JERSEY SHORE
    Posts
    4,498
    +1
    619
    Yep ,propane torch 8-10 seconds on all three sides right in the middle where the threads would be underneath...

    Hows your vise,sturdy?

  4. #4
    devils ride 250's Avatar
    Join Date
    Mar 2010
    Location
    lehigh valley pa
    Posts
    775
    +1
    124
    Thanks guys. The thing is it needs a new shaft for the pump upgrade anyways and the prop is due for a new one. Any opinions on prop choice?

  5. #5
    "just sayin".. jetdave56's Avatar
    Join Date
    Nov 2008
    Location
    JERSEY SHORE
    Posts
    4,498
    +1
    619
    Let me know if your need that black iron prop holder, I've lent it a Kawa rider friend last yr and made sooo much easier to take off...that nub gets chewed up real good in these vises..

    I can mail it to you...

  6. #6
    benjahw benjahw's Avatar
    Join Date
    Jan 2008
    Location
    Naples, Fl
    Posts
    467
    +1
    30
    I had 350+ hours on original prop when i upgraded bearings and prop. I actually had to have my pump machined on a lathe as it had swollen up and WOULD NOT allow a new prop to spin in the pump. You may have to do the same. Also I have a new 15/23 for the 250 if you go that route.

  7. #7
    devils ride 250's Avatar
    Join Date
    Mar 2010
    Location
    lehigh valley pa
    Posts
    775
    +1
    124
    Ok thanks. Now that I know what's up I'll keep u posted if I go with that Silas Thank u guys

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problems with TBM Pump Cone??
    By rick xp in forum Yamaha PWC Performance (4-stroke)
    Replies: 34
    Last Post: 06-15-2011, 02:59 AM
  2. Has anybody had problems with pump bolts coming loose?
    By MPower in forum 4-Tec Performance
    Replies: 19
    Last Post: 02-22-2009, 01:21 PM
  3. new guy with problems with fuel pump
    By crazuri2 in forum Polaris How To & FAQs
    Replies: 7
    Last Post: 07-24-2008, 07:34 PM
  4. Problems with GPR HO pumps
    By Autosport in forum Conversion PWC Performance Skis
    Replies: 2
    Last Post: 05-20-2008, 09:59 AM
  5. found big problem with my GP Pump shoe
    By Mr1300 in forum Yamaha PWC Performance (2-stroke)
    Replies: 15
    Last Post: 12-17-2007, 10:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •