Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
  1. #1
    ADAMBOMB's Avatar
    Join Date
    Mar 2006
    Location
    Sunrise,Florida
    Posts
    4,723
    +1
    196

    Wow... Scratching My Head...

    Well as most of you know im rebuilding my ski due to low compression from just rings. Im going through the whole ski making sure everyrhing is good. Well tonight this is what i found....What would have caused this? This is cracked in three diffrent places! So glad this didnt break apart and take out anything else!
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	20140409_001418.jpg 
Views:	168 
Size:	66.8 KB 
ID:	326378   Click image for larger version. 

Name:	20140409_001428.jpg 
Views:	149 
Size:	79.3 KB 
ID:	326380   Click image for larger version. 

Name:	20140409_001338.jpg 
Views:	189 
Size:	82.3 KB 
ID:	326379  


  2. #2
    Steve-m31164's Avatar
    Join Date
    Jan 2013
    Location
    Melbourne Australia
    Posts
    2,690
    +1
    403
    Good catch ! Lucky it didn't destroy yr pump and everything else

  3. #3
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    A few of the Yamaha guys have had issues with blades separating on Solas props.

  4. +1 by:


  5. #4
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Quote Originally Posted by ADAMBOMB View Post
    Well tonight this is what i found....What would have caused this?
    Cheap Chinese castings.

  6. +1 by:


  7. #5

    Join Date
    Sep 2010
    Location
    South Florida
    Posts
    1,599
    +1
    123
    Have one on m y bench, same issue.

  8. #6
    Tiny's Avatar
    Join Date
    Sep 2006
    Location
    The Atl
    Posts
    3,561
    +1
    578
    I have seen a Solas in a Yamaha completely fold a blade in half twice now.Both were race skis and both were FZR's.

  9. +1 by:


  10. #7
    EVN81's Avatar
    Join Date
    Jul 2013
    Location
    Terschelling - the Netherlands
    Posts
    462
    +1
    39
    Having a brand new Solas impeller and SS wearring ready on the workbench now.

    Maybe stick with the stock impeller?

    Luckily you found it out now and not while riding!

  11. #8
    Duke's Avatar
    Join Date
    Jul 2006
    Location
    Florida
    Posts
    10,004
    +1
    406
    Not trying to defend Solas because I do wish for better quality but wondering if its a percentage thing. I've had at least a 100 Solas 4 blades run through my shop and only one break a blade after I pitched it to many times. Also welded many out to 162 with no issues but this doesn't mean I haven't seen them. Many Yami props welded, pitched etc., yet I saw Big John break two on a VXR. I'm sure Jerry could give us an idea how many Solas 4 blades he has sold in the past few years.

    Skat makes a stronger hub prop but it seems at the cost of mph. At the same time I've seen cracks on Long blade Skat props for Yamahas.


    It does appear there is some rock/oyster bed damage on the trailing edge of Adam's prop also.

  12. #9
    Eastside Powersports Slow 91's Avatar
    Join Date
    Sep 2008
    Location
    River Crew CT
    Posts
    4,248
    +1
    544
    Quote Originally Posted by ADAMBOMB View Post
    Well as most of you know im rebuilding my ski due to low compression from just rings. Im going through the whole ski making sure everyrhing is good. Well tonight this is what i found....What would have caused this? This is cracked in three diffrent places! So glad this didnt break apart and take out anything else!
    too much boost lmao.

  13. #10
    Derek45's Avatar
    Join Date
    Feb 2014
    Location
    MO. Mark Twain, LOTO
    Posts
    461
    +1
    26
    Looks to be a decent size ding on that Blade same side as the major crack, wonder if that is what caused it or started the fracture

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Scratching my head at '13 fx ho overheating
    By GGG in forum Yamaha PWC Performance (4-stroke)
    Replies: 15
    Last Post: 07-14-2016, 05:36 AM
  2. Scratching my head on my 780
    By Superd2K in forum Polaris Open Discussion
    Replies: 2
    Last Post: 09-03-2012, 12:35 AM
  3. scratching my head
    By rwells173 in forum 4-Tec Performance
    Replies: 5
    Last Post: 10-09-2007, 07:44 PM
  4. My head will be here tomorrow!
    By Green Hulk in forum 4-Tec Performance
    Replies: 22
    Last Post: 05-22-2005, 09:18 PM
  5. Pictures of my head being ported
    By Green Hulk in forum 4-Tec Performance
    Replies: 17
    Last Post: 05-13-2005, 08:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •