Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1

    Join Date
    Feb 2014
    Location
    Newtown, PA
    Posts
    19
    +1
    4

    Transducer Help Please

    I have a 2013 FX Sho Cruiser and can not find a good location in the hull to mount the transducer, I am not interested in mounting it on the outside, if I can help it. Anyone have any ideas? I was considering buying a puck style, but I am not finding room for it.

    Any help would be appreciated


  2. #2
    jetskibrian's Avatar
    Join Date
    Nov 2009
    Location
    Poquoson Virginia
    Posts
    1,051
    +1
    188
    The new Yamahas are made of a composite called Nano-Excel that is not recommended to try and shoot through. Both my FXHO's are transom mounted.

  3. #3
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    This is on a 2011 VXs Nano Excel hull......No problems with the readings...stuck down with pure silicone......just behind the mid wall....Make sure there is NO air bubbles....
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	2011-05-14 VXS Depth Finder GPS 005.JPG 
Views:	565 
Size:	108.2 KB 
ID:	326473  

  4. #4
    same thing here...2013 vxs nano hull....pure silicone is the trick....never had a problem shooting through this material...

  5. #5
    FAT RAT's Avatar
    Join Date
    Mar 2013
    Location
    Northwest Georgia
    Posts
    96
    +1
    1
    Quote Originally Posted by oldschool69 View Post
    same thing here...2013 vxs nano hull....pure silicone is the trick....never had a problem shooting through this material...
    Hey guys I am having problems with my thru mount. I own a 2001 Yamaha SUV and have placed my transducer in the same place JSB did. I bought the Lowrance® Mark-4 Sonar/GPS Combo and I have mounted the transducer twice each time, not able to get a reading. I can pull it out of the silicone and throw the transducer in the water and it works fine. Is it bubles in my 100% silicone or something else?


  6. #6
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    Did you try a different location?

  7. #7
    FAT RAT's Avatar
    Join Date
    Mar 2013
    Location
    Northwest Georgia
    Posts
    96
    +1
    1
    Quote Originally Posted by Aquaholic6801 View Post
    Did you try a different location?
    I have not tried anywhere else. Not sure where else to try.

  8. #8
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    That may be an area where there are air bubbles in the hull? ....can you move it either direction a few inches and remount it?

  9. #9
    I know this is an old post, but I bought the helix 5 with sidescan, and am looking to transom mount the transducer on my fx ho 2014... There are warnings that say not to mount outside when going 65 or over, and 99% of the time I won't be, but it scared me that it has that warning.. if I'm going to be going close to that sometimes.. Anyone have any issues with this, or have experiences to go aroud this? I don't want to drill holes in my jetski, so I want to try and run a bracket from the step bar,

    thanks in advance,
    DAN

  10. #10
    Quote Originally Posted by dmtorre View Post
    I know this is an old post, but I bought the helix 5 with sidescan, and am looking to transom mount the transducer on my fx ho 2014... There are warnings that say not to mount outside when going 65 or over, and 99% of the time I won't be, but it scared me that it has that warning.. if I'm going to be going close to that sometimes.. Anyone have any issues with this, or have experiences to go aroud this? I don't want to drill holes in my jetski, so I want to try and run a bracket from the step bar,

    thanks in advance,
    DAN
    I'm probably the least experienced person on here to reply, but check out my last post re: external mounting.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need HELP Please!
    By GeoRXT in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-30-2006, 08:04 AM
  2. HEy Guys Need Help PLEASE!!!
    By SpeedStang95 in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-06-2006, 01:29 AM
  3. RXT 2005 Loose Hose - HELP PLEASE
    By BrAinZ in forum 4-Tec Performance
    Replies: 5
    Last Post: 04-12-2006, 12:28 PM
  4. Can some one Post! A little Help Please!
    By Angelse68cal in forum 4-Tec Performance
    Replies: 6
    Last Post: 08-04-2005, 07:57 PM
  5. RXP Handling !! Anyone help please
    By rxp_boy in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-17-2005, 02:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •