Results 1 to 6 of 6
  1. #1

    Polaris Genesis 1200 (Carbureted) doesn't rev smoothly above idle

    Hey guys,

    I recently acquired a 2000 Polaris Genesis 1200 (Carbureted) from a family friend, and it isn't in working condition. A brief history of this PWC: I was told that they ran it through some seaweed and destroyed the motor, and had a brand new motor put in. They claimed that after the new motor was put in, it never really ran right again. As the videos below show, it starts and idles fine, but when I give it any gas above idle, it sounds like it's skipping or something. It has virtually no thrust above idle in the water. I've tried changing the spark plugs, siphoning out the gasoline and putting fresh gas in, cleaning out the carbs, and I have no idea what to try next. If you PWC gurus have any suggestions, I'd be very appreciative. Thanks!




  2. #2

    Join Date
    Apr 2012
    Location
    Southern California
    Posts
    308
    well first thing i would check is compression make sure that engine is were it needs to be a good 1200 sould be around 120psi, next thing i would check is spark take each individual pug out and check them for spark being a carb ski the cdi are known for going bad, and lastly check the fuel even thou i doubt it it might be a stuck needle in the carbs. i hope this helps

  3. #3
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Are there any messages on the display? That sure sounds like its hitting the rev limiter.

  4. #4
    fixer's Avatar
    Join Date
    Feb 2011
    Location
    Mass
    Posts
    498
    +1
    20
    That's in limp mode. Unplug the display, wait 10 seconds & plug it back in then try it again. I had a 00' Virage that had something wrong with the MFD & that would clear up the problem until I shut it off & tried to start it again. I ended up replacing the MFD.

  5. #5
    The MFD is bad. The display is cracked and it looks like there is some moisture inside the screen. I ordered a new one yesterday in hopes that it would at least help me diagnose the problem. The weird thing is that it will sometimes (infrequently) take off no problem when I hit the throttle, but if I let off and let it get back down to idle, it would go into that "limp mode."

    I'll change out the MFD and see what happens. Thanks!

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,589
    +1
    1,273
    Quote Originally Posted by hookem91 View Post
    The MFD is bad. The display is cracked and it looks like there is some moisture inside the screen. I ordered a new one yesterday in hopes that it would at least help me diagnose the problem. The weird thing is that it will sometimes (infrequently) take off no problem when I hit the throttle, but if I let off and let it get back down to idle, it would go into that "limp mode."

    I'll change out the MFD and see what happens. Thanks!
    A bad MFI display can cause weird engine problems. Unplug and bypass the display at the connector on the back.

    The bypass (just a 14 gauge solid copper wire wire jumper) is necessary as the MFI display has a security Lock feature.

    See my signature links for how to bypass the security feature and start the engine without the display connected.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1999 Polaris Genesis 1200 Won't REV. Any ideas?
    By parson.phillip in forum Polaris Open Discussion
    Replies: 9
    Last Post: 07-21-2014, 10:47 PM
  2. 1999 Polaris Genesis 1200 Won't REV. Any ideas?
    By parson.phillip in forum Open Discussion
    Replies: 1
    Last Post: 07-21-2014, 08:16 PM
  3. Info Needed On Polaris Genesis 1200 Carb
    By A1999polaris1200ccgenesis in forum Polaris Open Discussion
    Replies: 12
    Last Post: 06-29-2008, 07:56 PM
  4. polaris genesis 1200 mods
    By polarisgen1200 in forum Polaris PWC Performance
    Replies: 22
    Last Post: 09-10-2007, 06:08 PM
  5. 1999 Polaris Genesis 1200 "Sleeper" project
    By SCXtrmSnwNWtr in forum Polaris Projects
    Replies: 23
    Last Post: 05-12-2007, 06:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •