Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1
    eschanen85's Avatar
    Join Date
    Mar 2013
    Location
    Corpus Christi Texas
    Posts
    59
    +1
    2

    Anybody running a innovate AFR gauge on a RXP?

    I installed a AFR gauge (LC-1) this weekend to see what my AFR's were prior to installing a RRFR here in a few weeks and I seem a lil puzzled with the readings. I have the Gauge powered off of the "Purple Wire" under the steering wheel and it is grounded to the Battery. I also calibrated it to the instruction's and when I started the ski up it started off reading 7.8 then a few seconds later it jumped to 10.8. I revved it a few times to a max of about 4000 rpms and the gauge just sat on 10.8. Does this sound right? or should the readings be fluctuating?
    Last edited by eschanen85; 04-14-2014 at 02:31 PM.


  2. #2
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    LC-1 or MTX-L?

  3. #3
    eschanen85's Avatar
    Join Date
    Mar 2013
    Location
    Corpus Christi Texas
    Posts
    59
    +1
    2
    LC-1

  4. #4
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Did you calibtate the O2 sensor???

  5. #5
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Load the LM Programmer software on a PC, and check to make sure the LC-1 is programmed for gasoline use.

  6. #6
    eschanen85's Avatar
    Join Date
    Mar 2013
    Location
    Corpus Christi Texas
    Posts
    59
    +1
    2
    Yea I did the calibration as per the instructions. I haven't hooked it up to a computer yet I will try that this weekend and see what it is set on. Hopefully that's all that is. I see that some people have had problems with the sensors being bad =/

  7. #7
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    3,851
    +1
    742
    If I remember correctly the LC-1 requires 2 separate grounds. This is very important! There are 2 bolts available on the front if the engine just below the exhaust manifold. Did you install the inline switch for fresh air calibration?

  8. #8
    ncdoo's Avatar
    Join Date
    Nov 2007
    Location
    Eastern NC
    Posts
    1,351
    +1
    105
    Sounds normal to me except they should be some variance through the throttle range. Mine flashes 7.4 for about 20 seconds during warmup them the actual reading start.

  9. #9
    Sayers's Avatar
    Join Date
    Jul 2010
    Location
    Melbourne AUS
    Posts
    2,300
    +1
    134
    Quote Originally Posted by jpt7779 View Post
    If I remember correctly the LC-1 requires 2 separate grounds. This is very important! There are 2 bolts available on the front if the engine just below the exhaust manifold. Did you install the inline switch for fresh air calibration?
    Blue and white go to ground. Black calibration wire gets the led and push button to ground (ground for 3 sec and it starts calibration).

  10. #10
    eschanen85's Avatar
    Join Date
    Mar 2013
    Location
    Corpus Christi Texas
    Posts
    59
    +1
    2
    The only wires I had on my gauge was a red, white, black brown and yellow. The only way I calibrate it is by pulling out the sensor and doing a dry run like the instructions say. =( When I do install the RRFR this week what its a good AFR number I should be looking for?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Innovate AFR Gauge with LM-2 Cable ... how to install?
    By FZR AD in forum Yamaha PWC Performance (4-stroke)
    Replies: 29
    Last Post: 08-21-2012, 10:44 PM
  2. Wiring up the Innovate AFR Gauge question?
    By skigolfnut in forum 4-Tec Performance
    Replies: 2
    Last Post: 11-20-2011, 08:35 PM
  3. mounting a innovate AFR gauge?
    By gordon lasiter #328 in forum Yamaha PWC Performance (4-stroke)
    Replies: 13
    Last Post: 07-29-2011, 09:51 PM
  4. FS Brand New Innovate AFR Gauge
    By krouchchocolate in forum Sea Doo Classifieds
    Replies: 9
    Last Post: 10-14-2010, 08:01 AM
  5. Anybody running 2 cyl base gaskets on GPR?
    By Robsauto2 in forum Yamaha PWC Performance (2-stroke)
    Replies: 26
    Last Post: 08-12-2007, 09:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •