Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1
    FallinOffHurts's Avatar
    Join Date
    Aug 2009
    Location
    Treasure Island Florida
    Posts
    298
    +1
    32

    Riva Athena Stage 2 ECU Top RPM's same as stock ECU!!!

    I am curious if anyone else is having the exact same issue as I am in regards to the Athena. My stock ECU tops out at 8040 RPM's. The Athena also tops out at 8040 RPM's. I will be making a video and timing the acceleration of the stock ECU vs the Athena ECU to ensure I am getting a performance gain. I have the full stage 2 kit installed on my machine as listed on Riva's site. I will also be checking top speed of the stock ECU vs the Athena with an aftermarket GPS. If anyone has had the same issue, please post up how you resolved it. Thanks for the help! Ski is a 2014 Sea Doo RXP-X


  2. #2
    SLASHER's Avatar
    Join Date
    Jun 2007
    Location
    Australia, Perth WA
    Posts
    3,263
    +1
    474
    Change prop or repitch

  3. +1 by:


  4. #3
    Sayers's Avatar
    Join Date
    Jul 2010
    Location
    Melbourne AUS
    Posts
    2,300
    +1
    134
    My prop speed jumped straight up, even running the stock map which I adjusted the RPM limit to suit.

  5. #4

    Join Date
    Mar 2013
    Location
    Appleton, WI
    Posts
    588
    +1
    93
    Stock and just adding Athena you should see a jump in RPM's. With all your mods and Athena you should for sure be pushing more RPM's, quite a bit more.

    Does the dream meter on the dash indicate a higher speed with the Athena ECU??

  6. #5

    Join Date
    Aug 2013
    Location
    Naples FL.
    Posts
    157
    +1
    18
    I agree with the rest above. I personally still run Athena but can say the rpms should have raised to maybe 8100-8200ish on a stock setup or with Stage 2. You should be around 73-74mph on the dash, if not then the prop is most likely holding it back.

  7. #6
    FallinOffHurts's Avatar
    Join Date
    Aug 2009
    Location
    Treasure Island Florida
    Posts
    298
    +1
    32
    I have seen no additional RPM's with the Athena whatsoever. I am running the Solas 15/19 prop. I think it is odd that the stock ECU and the Athena ECU run the EXACT same RPM up top. The dash shows 70-71 with the Athena. I will be putting together a side by side comparison video this weekend comparing the Athena ECU to the stock ECU. I also have an aftermarket GPS to measure the exact speed with each ECU. So far I am not sold on the Athena and the performance it's supposed to have. Riva is logging into the Athena on the ski in the morning to attempt to correct very poor and rough idle conditions as well as sluggish response when first pulling the throttle back. I have already verified I have the correct map and firmware installed. Let's hope for the best! Maybe I should've gone straight to the mo-tec....

  8. #7

    Join Date
    Mar 2013
    Location
    Appleton, WI
    Posts
    588
    +1
    93
    Your not the only one that has had quite a few issue with Athena. Seems like for everyone that works out a few are in for a rough road.

    Hopefully they can get it squared away for you. Also most on here seem to like to start with the 15/20 pitch on the RXPX running say a 8350 tune.

  9. #8

    Join Date
    Aug 2013
    Location
    Naples FL.
    Posts
    157
    +1
    18
    Quote Originally Posted by FallinOffHurts View Post
    I have seen no additional RPM's with the Athena whatsoever. I am running the Solas 15/19 prop. I think it is odd that the stock ECU and the Athena ECU run the EXACT same RPM up top. The dash shows 70-71 with the Athena. I will be putting together a side by side comparison video this weekend comparing the Athena ECU to the stock ECU. I also have an aftermarket GPS to measure the exact speed with each ECU. So far I am not sold on the Athena and the performance it's supposed to have. Riva is logging into the Athena on the ski in the morning to attempt to correct very poor and rough idle conditions as well as sluggish response when first pulling the throttle back. I have already verified I have the correct map and firmware installed. Let's hope for the best! Maybe I should've gone straight to the mo-tec....
    You will get this worked out, don't sweat it. Athena works very well when everything is setup correctly. Its hard to diagnose something online but Rob C @ Riva will get it all straightened out and you will have a big smile on your face doing 75ish-

  10. #9

    Join Date
    May 2010
    Location
    Jax,FL
    Posts
    3,444
    +1
    653
    what is the air temperature when riding...

    Stage 2 is 72 best case @ 75f 1/3 tank a gas - Air temperature makes a big difference, salt water take another 1mph away. Athena runs very conservative timing maps. I will admit it sounds a bit low. Are you sure you have the stage 2 map loaded and not the stage 1? I'd reload the stage 2 map.

    If there is one thing I know, it's how to spend a bunch a money and go slow.

  11. #10
    FallinOffHurts's Avatar
    Join Date
    Aug 2009
    Location
    Treasure Island Florida
    Posts
    298
    +1
    32
    Yes I am sure it's the stage 2 map. I figured I would at least see SOME difference in top RPM's with the Athena vs the stock ECU. The ski only had 7 hours on it when I put the Athena in. I assume the ECU is what was limiting the RPM's during break in which is why I went 2 hours past the 5 hour break in on the stock ECU. Riva has offered to help me figure it out if I take the ski to their facility and pay $130 per hour.....

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Is the VTech stock flash exactly the same as stock ECU?
    By Gus13letter in forum 4-Tec Performance
    Replies: 10
    Last Post: 04-18-2015, 11:09 AM
  2. FS RIVA Athena Pro Series ECU
    By RichieFZR in forum Yamaha Classifieds
    Replies: 5
    Last Post: 10-07-2013, 06:01 PM
  3. Riva / Athena stage kits for the 2012 rxp x260 Need info.
    By Tonyrxpx in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-10-2013, 05:02 PM
  4. 2007 rxt riva stage 1 kit 7500 rpms
    By hydrojunkie in forum 4-Tec Performance
    Replies: 31
    Last Post: 07-14-2007, 08:30 PM
  5. RXP Stage 1 Installed Lost Rpms/Top speed
    By Colby in forum 4-Tec Performance
    Replies: 5
    Last Post: 01-28-2007, 03:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •