Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    2002 gtx 4tec Check Engine problem.

    Hello i have a 2002 sea-doo gtx 4tec that have what seems to be a common problem,a Check Engine problem.
    every time i run it after 20 minutes or less a long beep comes on and "CHK ENG" dispays on my lcd screen. when it happens it wont let me go over 2500-3000 rpm after the check engine starts I remove the key and restarte the engine again and it all works fine to 10-20 minutes until it happens again.
    i have been in the dealership for many times and they replaced 2 "oil pressure sensors" and it didnt help, they also tried to use an other computer (mpem) in my ski and that didnt work as well...
    They say i need to replace the electrical system, could that be the answere to my problem ???
    what kind of things can cause the Check Engine problem???
    pleas help me and give me some advice...
    thenk you .avi.


  2. #2

    Join Date
    Feb 2006
    Location
    Birmingham AL
    Posts
    2,924
    +1
    2
    When it does it push the mode button 5 times and get the code

  3. #3
    2&4strokepolaristech's Avatar
    Join Date
    Aug 2006
    Location
    Oswego,NY
    Posts
    919
    +1
    6
    just like as mentioned what code are you getting? it could be a bad T.O.P.S. Valve. just as lvnspeed said hit the mode button 5 times and see what code comes up.

  4. #4
    Banned User
    Join Date
    Jul 2006
    Location
    upstate NY
    Posts
    289
    They are famous for the oil pressure sensor code #1202 with is located on the filler tube of your machine. Ive replaced 50 or so of them. The part is $25.00 and can be replaced by you. I stk them if you want to purchase it and replace it yourself. If so PM me. JOJO

  5. #5
    i have hit the "SET" button 5 times and the screen flashed at me code number P-1681 what dose it means ???
    thenk you avi.

  6. #6

    Join Date
    Jul 2005
    Location
    euxton nr chorley lancashire, england
    Posts
    1,500
    +1
    1
    kabab check this out, regards bill ps save it to your favourites for future refrancehttp://www.sea-doo.net/Specifications/4-TEC-DIAGNOSTIC-PROCEDURES.pdf

  7. #7
    Thenk you very much for your help.

  8. #8
    Hello i have a 2002 sea-doo gtx 4tec and just brought it i have replaced all the plugs and coil packs changed the oil and filters but it still only hits 50mph is this normal????? It has only one lanyard which is the learner one but has been recoded by the last owner will this make a difference any help wold be handy ..............

  9. #9
    jpeconsult's Avatar
    Join Date
    Jul 2007
    Location
    Pineville, LA
    Posts
    5,448
    +1
    1
    Quote Originally Posted by Biglove666 View Post
    Hello i have a 2002 sea-doo gtx 4tec and just brought it i have replaced all the plugs and coil packs changed the oil and filters but it still only hits 50mph is this normal????? It has only one lanyard which is the learner one but has been recoded by the last owner will this make a difference any help wold be handy ..............
    With ski level and warm...Oil should be no more than 1/2 way between the bends on the dip stick. Check impeller and wearring. --J

  10. #10
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Quote Originally Posted by Biglove666 View Post
    Hello i have a 2002 sea-doo gtx 4tec and just brought it i have replaced all the plugs and coil packs changed the oil and filters but it still only hits 50mph is this normal????? It has only one lanyard which is the learner one but has been recoded by the last owner will this make a difference any help wold be handy ..............
    What rpms are you seeing at 50 mph? Why were the coil packs changed? ... Ron

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 GTX 4Tec - Won't start - Check engine code P1656
    By KiloRomeo in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 08-25-2014, 01:26 PM
  2. 2002 GTX 4TEC drive shaft problems
    By taylor757 in forum 4-Tec Performance
    Replies: 10
    Last Post: 07-16-2012, 06:43 PM
  3. 2002 GTX 4tec Wont run... Low compression
    By rhislo in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 10-06-2009, 07:36 PM
  4. info center wanted for 2002 gtx 4tec
    By tweeker in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 05-20-2008, 01:50 PM
  5. wanted 2002 gtx 4tec mpem
    By tweeker in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 05-20-2008, 12:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •