Results 1 to 6 of 6
  1. #1
    Lightning1's Avatar
    Join Date
    Mar 2013
    Location
    Illinois
    Posts
    367
    +1
    29

    Prop stud broke, wreaked havoc

    Good morning guys, I have an issue that arose this weekend on the first ride. The stud that the prop threads on to sheared off this weekend and took out the pump, pump shoe, prop and my PRV setup that I installed last week even. The stud looks like it was cracking last year looking at it, then decided to let go on Saturday.

    My question is, is this something that has been seen before? My ski is an 09 PX with some mods, but nothing crazy, and it has 111 hours on it, which isn't real high either.

    Also, obviously I will need to get all the parts used, or this ski just wont be worth fixing, what year skis can I get parts off of (I assume 04-09 RXP and RXPX) but wanted to be sure before getting parts. Also, how can I test the shaft to ensure that this wont happen again?

    This really put a damper on my spring as I am at the point of going and looking at a spark or something cheap as it seems like I am just constantly fixing this PX and the parts arn't getting any cheaper. Thanks for reading and for any input,

    Jeff


  2. #2
    Tiny's Avatar
    Join Date
    Sep 2006
    Location
    The Atl
    Posts
    3,561
    +1
    578
    I would check for metal in the oil. In a worst case the prop may have moved forward and took out your thrust washers on the crank.

    Yes, a broken impeller shaft is something I have seen before. Not very common but can happen.

  3. #3
    GRF + DashPac:) seadoo02xp's Avatar
    Join Date
    Apr 2005
    Location
    MO
    Posts
    4,559
    +1
    948
    This happened to me. I don't want to ruin your day or anything but if you didn't immediately shut off your engine you very likely took out your thrust bearing in your engine. Since the prop had nothing holding it back it drove your driveshaft into your motor. Check your oil and look for metal. Shaft alignment and or shaft play can cause this

  4. #4
    Lightning1's Avatar
    Join Date
    Mar 2013
    Location
    Illinois
    Posts
    367
    +1
    29
    This is something I was afraid of. I have a feeling though you are right about the thrust washer though. It may be time to park this and start looking for something new to ride this year, such a shame.

  5. #5
    dsteinmann's Avatar
    Join Date
    Apr 2012
    Location
    St Louis
    Posts
    278
    +1
    8
    Yep happened to me to once, The prop came loose and took out the thrust bearing and block and crank and .... Wanna Sell it?

  6. #6
    Lightning1's Avatar
    Join Date
    Mar 2013
    Location
    Illinois
    Posts
    367
    +1
    29
    I am not going to sell it, if anything it will be rebuilt over the winter. Too many parts to sell it outright anyways. It will be built and turn into a real project/toy. I guesss it is time to find a stock rec rider now.

    It just sucks it happened within the first 4 miles of the year on the first day. All that time messing with it over the winter and it is taken out by something unforseen.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. solas prop compared to stock repitched
    By nitro rxp in forum 4-Tec Performance
    Replies: 23
    Last Post: 12-17-2007, 10:31 AM
  2. solas prop
    By nitro rxp in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-08-2005, 09:54 PM
  3. Have stage I minus the prop, looking for more mods..
    By 05rxt in forum 4-Tec Performance
    Replies: 17
    Last Post: 06-08-2005, 07:07 AM
  4. SRX-CD 13/19 RXT Prop avail at Riva
    By UFO-RXT in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-05-2005, 12:21 AM
  5. 4-TEC props
    By Phil in forum 4-Tec Performance
    Replies: 51
    Last Post: 05-26-2005, 12:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •